Problem with scripts

3 posts, 1 answers
  1. Bahar
    Bahar avatar
    2 posts
    Member since:
    Nov 2011

    Posted 02 Nov 2011 Link to this post

    hi
    i am using the latest version of radeditor  , radeditor works properly , bu i thinks it's scripts conflicts with my scripts that i have used in my cms, i have used component art menu, when the first time page loads my page shows menu and radeditor works well ,but after refreshing the page , and when the session has time out, i loggin again , and the menu disappears, i think the menu conflict with radeditor.

    Best Regards Bahar
    ----------------------------------------
    <%@ Register TagPrefix="ComponentArt" Namespace="ComponentArt.Web.UI" Assembly="ComponentArt.Web.UI" %>

     <td style="width: 100%; text-align: right">
                                <ComponentArt:Menu ID="Mnumain" runat="server" ClientTarget="Auto" CssClass="TopGroup"
                                    DefaultGroupCssClass="MenuGroup" CausesValidation="False" DefaultItemLookId="DefaultItemLook"
                                    DefaultGroupExpandDirection="BelowRight" DefaultChildSelectedItemLookId="SelectChildItemLook"
                                    DefaultSelectedItemLookId="SelectItemLook">
                                    <ItemLooks>
                                        <ComponentArt:ItemLook LookId="TopItemLook" CssClass="TopMenuItem" HoverCssClass="TopMenuItemHover" />
                                        <ComponentArt:ItemLook LookId="SelectItemLook" CssClass="SelectMenuItem" />
                                        <ComponentArt:ItemLook LookId="SelectChildItemLook" CssClass="SelectChildMenuItem" />
                                        <ComponentArt:ItemLook LookId="DefaultItemLook" CssClass="MenuItem" HoverCssClass="MenuItemHover" />
                                    </ItemLooks>
                                </ComponentArt:Menu>
                            </td>
    -------------------------------------------------------------------------------------------
    web.cong

    <?xml version="1.0"?>
    <configuration>
      <configSections>
        <sectionGroup name="Miron.web">
          <section name="CompressorSettings" type="Miron.Web.MbCompression.SettingsConfigSection" />
        </sectionGroup>
        <sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
          <sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
            <section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
            <sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
              <section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerializationSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="Everywhere" />
              <section name="profileService" type="System.Web.Configuration.ScriptingProfileServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
              <section name="authenticationService" type="System.Web.Configuration.ScriptingAuthenticationServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
              <section name="roleService" type="System.Web.Configuration.ScriptingRoleServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
            </sectionGroup>
          </sectionGroup>
        </sectionGroup>
      </configSections>
      <appSettings>
        <!--<add key="DBNAME" value="Data Source=62.193.12.207;Initial Catalog=shahrdari;User ID=sa;Password=qwe1234"/>-->
        <!--<add key="DBNAMEShahryarnews" value="Data Source=62.193.12.207;Initial Catalog=shahryar;User ID=sa;Password=qwe1234"/>-->
         <!-- <add key="DBNAME" value="Data Source=server;Initial Catalog=Test-Rad;User ID=sa;Password=Qwe1234" />-->
      <add key="DBNAME" value="Data Source=pserver;Initial Catalog=Test-Rad;User ID=sa;Password=Qwe123"/>
        <add key="ExternalDBNAME" value="Data Source=192.168.1.1;Initial Catalog=Externalelib;User ID=sa;Password=1234" />
        <add key="SiteUrl" value="http://itshams.ir" />
        <add key="email" value="info@itshams.ir" />
        <add key="Hejri" value="-1" />
        <add key="SSlEmail" value="false" />
      </appSettings>
      <system.net>
        <mailSettings>
          <smtp>
            <network host="mail.itshams.ir" port="25" userName="vosei@itshams.ir" password="09141091985" />
          </smtp>
        </mailSettings>
        <!--<mailSettings>
                <smtp>
                    <network host="smtp.gmail.com" port="587" userName="sazmane.amar@gmail.com" password="sazman5564" defaultCredentials="false"/>
                </smtp>
            </mailSettings>-->
      </system.net>
      <system.web>
        <httpRuntime maxRequestLength="409600" executionTimeout="300" />
        <customErrors mode="Off" />
        <compilation debug="true" urlLinePragmas="true">
          <assemblies>
            <add assembly="System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
            <add assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
            <add assembly="System.Xml.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
            <add assembly="System.Data.DataSetExtensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
            <add assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
            <add assembly="System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
            <add assembly="System.Windows.Forms, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
          </assemblies>
        </compilation>
        <httpHandlers>
          <add verb="*" path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler, Telerik.Web.UI, Culture=neutral, PublicKeyToken=121fae78165ba3d4">
          </add>
          <add path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" verb="*" validate="false" />
          <add path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" validate="false" />
          <add verb="*" path="jslib.axd" type="Miron.Web.MbCompression.JavaScriptCompressionHandler" validate="true" />
          <add verb="*" path="css.axd" type="Miron.Web.MbCompression.CssCompressionHandler" validate="false" />
          <add verb="GET" path="CaptchaImage.aspx" type="WebControlCaptcha.CaptchaImageHandler, WebControlCaptcha" />
          <add verb="*" type="ComponentArt.Web.UI.UploadProgressHandler,ComponentArt.Web.UI" path="ComponentArtUploadProgress.axd" />
          <add verb="*" path="*js.axd" type="JavaScriptHandler" />
          <remove verb="*" path="*.asmx" />
          <add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          <add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          <add verb="GET,HEAD" path="ScriptResource.axd" validate="false" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
         
        </httpHandlers>
        <httpModules>
          <add name="RadCompression" type="Telerik.Web.UI.RadCompression" />
          <add name="RadUploadModule" type="Telerik.Web.UI.RadUploadHttpModule, Telerik.Web.UI" />
          <add type="ComponentArt.Web.UI.UploadModule,ComponentArt.Web.UI" name="ComponentArtUploadModule" />
          <add type="CompressWebResource" name="CompressWebResource" />
          
          <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
        </httpModules>
        <authentication mode="Windows" />
        <pages>
          <controls>
            <add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
            <add tagPrefix="asp" namespace="System.Web.UI.WebControls" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          </controls>
        </pages>
      </system.web>
      <Miron.web>
        <CompressorSettings reflectionAlloweded="false" optimizeHtml="true" daysInCahe="30" compressCSS="true" compressJavaScript="true" compressPage="false" compressWebResource="false" compressThirdParityScripts="false">
          <excludeTypes>
            <add key="image/gif" />
            <add key="image/jpeg" />
          </excludeTypes>
          <excludePaths>
            <!--<add key="~/DontCompressMe.aspx" />-->
          </excludePaths>
        </CompressorSettings>
      </Miron.web>
      <system.webServer>
        <handlers>
          <remove name="WebServiceHandlerFactory-Integrated" />
          <remove name="ScriptHandlerFactory" />
          <remove name="ScriptHandlerFactoryAppServices" />
          <remove name="ScriptResource" />
          <add name="Telerik.Web.UI.DialogHandler" path="Telerik.Web.UI.DialogHandler.aspx" verb="*" type="Telerik.Web.UI.DialogHandler, Telerik.Web.UI" />
          <add name="Telerik.Web.UI.DialogHandler.aspx_*" path="Telerik.Web.UI.DialogHandler.aspx" verb="*" type="Telerik.Web.UI.DialogHandler, Telerik.Web.UI, Culture=neutral, PublicKeyToken=121fae78165ba3d4" preCondition="integratedMode" />
          <add name="Telerik.RadUploadProgressHandler.ashx_*" path="Telerik.RadUploadProgressHandler.ashx" verb="*" type="Telerik.Web.UI.Upload.RadUploadProgressHandler, Telerik.Web.UI" preCondition="integratedMode" />
          <add name="Telerik_Web_UI_SpellCheckHandler_axd" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" />
          <add name="Telerik_Web_UI_WebResource_axd" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" />
          <add name="JsHandler" verb="*" path="jslib.axd" type="Miron.Web.MbCompression.JavaScriptCompressionHandler, MbCompression" preCondition="integratedMode" />
          <add name="CssHandler" verb="*" path="css.axd" type="Miron.Web.MbCompression.CssCompressionHandler, MbCompression" preCondition="integratedMode" />
          <add name="ScriptHandlerFactory" verb="*" path="*.asmx" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          <add name="ScriptHandlerFactoryAppServices" verb="*" path="*_AppService.axd" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          <add name="ScriptResource" verb="GET,HEAD" path="ScriptResource.axd" preCondition="integratedMode" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          <add name="ChartImage.axd_*" path="ChartImage.axd" verb="*" type="Telerik.Web.UI.ChartHttpHandler, Telerik.Web.UI, Culture=neutral, PublicKeyToken=121fae78165ba3d4" preCondition="integratedMode" />
          
        </handlers>
        <validation validateIntegratedModeConfiguration="false" />
        <modules>
          <remove name="ScriptModule" />
           
          <add name="ScriptModule" preCondition="managedHandler" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
        </modules>
      </system.webServer>
      <system.codedom>
        <compilers>
          <compiler language="c#;cs;csharp" extension=".cs" type="Microsoft.CSharp.CSharpCodeProvider,System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" warningLevel="4">
            <providerOption name="CompilerVersion" value="v3.5" />
            <providerOption name="WarnAsError" value="false" />
          </compiler>
          <compiler language="vb;vbs;visualbasic;vbscript" extension=".vb" type="Microsoft.VisualBasic.VBCodeProvider, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" warningLevel="4">
            <providerOption name="CompilerVersion" value="v3.5" />
            <providerOption name="OptionInfer" value="true" />
            <providerOption name="WarnAsError" value="false" />
          </compiler>
        </compilers>
      </system.codedom>
      <runtime>
        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
          <dependentAssembly>
            <assemblyIdentity name="System.Web.Extensions" publicKeyToken="31bf3856ad364e35" />
            <bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0" />
          </dependentAssembly>
          <dependentAssembly>
            <assemblyIdentity name="System.Web.Extensions.Design" publicKeyToken="31bf3856ad364e35" />
            <bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0" />
          </dependentAssembly>
        </assemblyBinding>
      </runtime>
    </configuration>
    -------------------------------------------------------------------------------------------------------------------------------------------------
    Rad Editor

    <telerik:RadScriptManager ID="ScripttxtContent" runat="server" EnableScriptCombine="False" />
                                        <telerik:RadEditor ID="txtContent" runat="server" Width="100%" Skin="Telerik" EnableResize="False"
                                            ToolsFile="~/admin/Rad-Editor/Tools.xml" ExternalDialogsPath="~/RadControls/Editor/EditorDialogs"
                                            ToolbarMode="Default" StripFormattingOnPaste="MSWordNoFonts" ContentFilters="None"
                                            AllowScripts="True" ImageManager-MaxUploadFileSize="20971520" DocumentManager-MaxUploadFileSize="20971520"
                                            FlashManager-MaxUploadFileSize="20971520" MediaManager-MaxUploadFileSize="20971520"
                                            EnableTheming="False">
                                        </telerik:RadEditor>
    -----------------------------------------------------------------------------------------------------
  2. Answer
    Rumen
    Admin
    Rumen avatar
    14466 posts

    Posted 02 Nov 2011 Link to this post

    Hi Bahar,

    The scope of our support services is concentrated on our products only and we do not support third party components. If you would like you can replace the Component's Art menu with RadMenu for ASP.NET AJAX and you should not experience problems with it.

    In other case, my suggestion is to contact the developers of Component Art and report the problem concerning their menu control.

    Best regards,
    Rumen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now
  3. Bahar
    Bahar avatar
    2 posts
    Member since:
    Nov 2011

    Posted 05 Nov 2011 Link to this post

    Hi Rumen

    Thanks for your answer ...:)

    Best Regards

    Bahar
Back to Top