Parent window gets resized in IE9

2 posts, 0 answers
  1. Stephen
    Stephen avatar
    1 posts
    Member since:
    Apr 2013

    Posted 17 May 2013 Link to this post

    I have a strange bug where if i click to open the window, it opens the modal and the parent window gets resized according to the width and height i had entered in the radwindowmanager controls.

    If i remove these sizes then i don't get this bug. No problem in chrome etc just IE.

    I am using the Twitter Bootstrap framework and it would seem the popup is triggering the responsive CSS which should only kick in on certain screen sizes.

    If i remove this CSS then i don't have this bug but really i need this to be in place.  Has anyone ever encountered this before?

  2. Marin Bratanov
    Marin Bratanov avatar
    5467 posts

    Posted 21 May 2013 Link to this post


    I have not encountered this before and I am afraid that this may be a behavior of the bootstrap that we cannot change. RadWindow is the same in all browsers - an absolutely positioned DIV element with the given dimensions that is a direct child of the <form> element. The fact that such an element causes the framework to misbehave is not something we can influence. What I can suggest you try is setting some dimensions to the html, body and form elements to accommodate such a div and the other content from the page. Another thing you can try is setting the dimensions of the popup only after it is show via its Client-side API (the setSize(width, height) method). You can also try storing the current browser size in the OnClientBeforeShow event of the RadWindow, then restoring that after the bootstrap has changed it. The isIE check and the getClientBounds() method from our static client library can be useful for this.

    Marin Bratanov
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
Back to Top