This is a migrated thread and some comments may be shown as answers.

Pager is not displayed

4 Answers 45 Views
Grid
This is a migrated thread and some comments may be shown as answers.
Blake
Top achievements
Rank 1
Blake asked on 20 Oct 2011, 05:58 PM
I have RadGrid control on my page, when I look at it in design view it shows the pager. When I compile the project I see no pager at the bottom of the grid.

Here is my code for the grid.

<telerik:RadGrid ID="rgResults" runat="server" Skin="WebBlue" AllowPaging="true"
            AllowSorting="true" PageSize="20" ShowFooter="true" GridLines="None"
            AutoGenerateColumns="false" onpageindexchanged="rgResults_PageIndexChanged"
            onpagesizechanged="rgResults_PageSizeChanged" EnableViewState="true"
            onsortcommand="rgResults_SortCommand">
            <PagerStyle Mode="NextPrevAndNumeric" AlwaysVisible="true" ShowPagerText="false" />
            <MasterTableView>
                <Columns>
                    <telerik:GridBoundColumn DataField="U_Prefix" HeaderText="Prefix" UniqueName="U_Prefix" SortExpression="U_Prefix"></telerik:GridBoundColumn>
                    <telerik:GridBoundColumn DataField="CardCode" HeaderText="Card Code" UniqueName="CardCode" SortExpression="CardCode"></telerik:GridBoundColumn>
                    <telerik:GridBoundColumn DataField="U_LastName" HeaderText="Last Name" UniqueName="U_LastName" SortExpression="U_LastName"></telerik:GridBoundColumn>
                    <telerik:GridBoundColumn DataField="U_FirstName" HeaderText="First Name" UniqueName="U_FirstName" SortExpression="U_FirstName"></telerik:GridBoundColumn>
                    <telerik:GridBoundColumn DataField="Phone1" HeaderText="Phone 1" UniqueName="Phone1" SortExpression="Phone1"></telerik:GridBoundColumn>
                    <telerik:GridBoundColumn DataField="Phone2" HeaderText="Phone 2" UniqueName="Phone2" SortExpression="Phone2"></telerik:GridBoundColumn>
                    <telerik:GridBoundColumn DataField="E_Mail" HeaderText="Email" UniqueName="E_Mail" SortExpression="E_Mail"></telerik:GridBoundColumn>
                    <telerik:GridBoundColumn DataField="Frozenfor" HeaderText="On Hold" UniqueName="Frozenfor" SortExpression="Forzenfor"></telerik:GridBoundColumn>
                    <telerik:GridHyperLinkColumn DataNavigateUrlFields="CardCode" Text="Edit" DataNavigateUrlFormatString="Customer.aspx?cc={0}"></telerik:GridHyperLinkColumn>
                </Columns>
            </MasterTableView>
        </telerik:RadGrid>

4 Answers, 1 is accepted

Sort by
0
Princy
Top achievements
Rank 1
answered on 24 Oct 2011, 07:39 AM

Hello Blake,

Tried working on your code and everything seems to be working fine. I am using 2011, 2, 712, 35. How about you?

Thanks,
Princy.
0
Blake
Top achievements
Rank 1
answered on 25 Oct 2011, 03:14 PM
I'm using 2011,2,915,40
0
Accepted
Jayesh Goyani
Top achievements
Rank 2
answered on 25 Oct 2011, 05:07 PM
Hello,

Please check that there is not any (globally) skin/theme applied to your RadGrid.

Thanks,
Jayesh Goyani
0
Blake
Top achievements
Rank 1
answered on 25 Oct 2011, 06:29 PM
Found it! It was one of my style sheets causing the problem. I had some custom styles for the jQuery addon dataTables, which causes the pager not to show up.
Tags
Grid
Asked by
Blake
Top achievements
Rank 1
Answers by
Princy
Top achievements
Rank 1
Blake
Top achievements
Rank 1
Jayesh Goyani
Top achievements
Rank 2
Share this question
or