This is a migrated thread and some comments may be shown as answers.

Operation is not supported error

2 Answers 194 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Cindy
Top achievements
Rank 1
Cindy asked on 31 Jan 2017, 08:56 PM

Getting frustrated - 

Long time user of Telerik. I have a new Windows 10 build. clean installation of Visual Studio 2013. The only version of Telerik on this computer is 2017.1.118.45. I used the Telerik Control Panel to install Telerik into VS 2013. 

New Telerik Web Project. Give it a name. Select the Responsive web app. Compile and test - works great. Add a new page. Drop a radgrid on the page. 

'Could not load file or assembly 'Telerik.Web.UI, Version=2017.1.118.45, Culture=neutral, PublicKeyToken=121fae78165ba3d4' or one of its dependencies. Operation is not supported. (Exception from HRESULT: 0x80131515)'\\XXXXX\LCxxxxx

Delete the newly added page. Same problem. Permissions all seem OK on the Telerik files. Same result if I run Visual Studio as an admin or regular user. 

Thanks,

 

Dan

2 Answers, 1 is accepted

Sort by
0
Cindy
Top achievements
Rank 1
answered on 01 Feb 2017, 04:48 PM
Hmmm ... Might be a folder redirection issue with Windows 10? We have our user "Documents" folder redirected to a server. Fails every time with the project at this location. Move to the local hard drive and it functions. So it would seem to be a permission issue somewhere, but it doesn't really explain why the project works before I add my own radgrid to the project despite there being a radgrid in the Telerik generated code. 
0
Marin Bratanov
Telerik team
answered on 03 Feb 2017, 11:10 AM

Hello Dan,

I suggest you try adding the Telerik references manually to ensure they point correctly to the ~/Bin folder: http://docs.telerik.com/devtools/aspnet-ajax/installation/upgrading-instructions/upgrading-a-trial-to-a-developer-license-or-to-a-newer-version#manual-upgrade.

My best guess at this point is that the automated wizard has put the assemblies in a lib folder out of the solution and something goes amiss with the Windows permissions. If all assemblies are in the BIN, this should be resolved. Also, this will make it easier for you to maintain in a source control system, run automated builds and to deploy.

Regards,

Marin Bratanov
Telerik by Progress
Try our brand new, jQuery-free Angular 2 components built from ground-up which deliver the business app essential building blocks - a grid component, data visualization (charts) and form elements.
Tags
General Discussions
Asked by
Cindy
Top achievements
Rank 1
Answers by
Cindy
Top achievements
Rank 1
Marin Bratanov
Telerik team
Share this question
or