Not dispayling in lists

3 posts, 0 answers
  1. Dan Lewis
    Dan Lewis avatar
    13 posts
    Member since:
    Feb 2005

    Posted 15 Feb 2008 Link to this post


    I have installed the Editor solution fine on my development VM. The solution deployed OK, I activated both features on a site and could see and add the Editor web part and also see the rad editor in lists.

    Having successfully tested in my development environment, I then deployed to our live WSS server. The solution installed OK using "stsadm -o addsolution -filename RadEditorMOSS.wsp"

    I then deployed the solution to all content databases which also worked fine. I activated both features in a site, and although I can now see the RadEditor web part, and can add it successfully to a page, the RadEditor does not display in any list items. I have tried this in both IE and Firefox.

    I have tried retracting, deleting, re-adding and re-deploying the solution several times, but always get the same behavior. The two features are visible under 12\TEMPLATE\Feature and the editor folders are present under wpresources. The only difference is that my dev machine also has RadEditorList.ascx under 12\TEMPLATE\CONTROLTEMPLATES as well as in RadEditorFeature, whereas the live server does not have the file in CONTROLTEMPLATES.

    The solution was installed as a farm admin. The only major difference between the two systems I can think of is that the live system uses a database on another server and is more locked down in terms of service accounts (less-privileges).

    Can you offer any help?


  2. Georgi Tunev
    Georgi Tunev avatar
    7207 posts

    Posted 19 Feb 2008 Link to this post

    Hello Dan,

    The information that you provided leads me to believe that the admin user that you have used to deploy the solution on your live server doesn't have enough privileges over the file system and cannot copy the RadEditorList.ascx file in the appropriate folders.

    Please either repeat the deployment with an account which has such rights, or copy the
    RadEditorList.ascx file manually in the corresponding folders on your live server. This should solve the problem that you are experiencing.

    All the best,
    Georgi Tunev
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. Dan Lewis
    Dan Lewis avatar
    13 posts
    Member since:
    Feb 2005

    Posted 19 Feb 2008 Link to this post

    Thanks Georgi,

    I copied over the .ascx manually and it is now working. I had tried doing that before but it didn't seem to work. This time it worked after copying and then doing an IIS reset which maybe I forgot to do last time around...

    BTW, I am in the local machine's administrators group and also explictly listed in the WSS farm administrators group, so it would be strange if I didn't have permission and the fact that all of the other files copied across OK apart from .ascx into CONTROLTEMPLATES?

    Anyway, I am happy it is working and will just leave this one as a mystery!


Back to Top