This is a migrated thread and some comments may be shown as answers.

Media Manager ot playing media

1 Answer 30 Views
Editor
This is a migrated thread and some comments may be shown as answers.
avichal
Top achievements
Rank 1
avichal asked on 23 Mar 2010, 12:49 PM
hi ,

I am using Media manager in radeditor.
its inserting the object tag properly but media is not playing at all ??
Am i missing something ?
here is my code

<

 

telerik:RadEditor ID="ReportsEditor" runat="server" Height="300px"

 

 

SkinID="DefaultSetOfTools" Width="100%" AutoResizeHeight=true HasPermission="True" >

 

 

<Modules>

 

 

<telerik:EditorModule Name="RadEditorStatistics" Visible="false" Enabled="true" />

 

 

<telerik:EditorModule Name="RadEditorDomInspector" Visible="false" Enabled="true" />

 

 

<telerik:EditorModule Name="RadEditorNodeInspector" Visible="false" Enabled="true" />

 

 

<telerik:EditorModule Name="RadEditorHtmlInspector" Visible="false" Enabled="true" />

 

 

</Modules>

 

<

 

Content>

 

</

 

Content>

 

 

</telerik:RadEditor>


 

protected

 

void Page_Load(object sender, EventArgs e)

 

{

ReportsEditor.ImageManager.ViewPaths =

new string[] { "~/Images" };

 

ReportsEditor.ImageManager.UploadPaths =

new string[] { "~/Images" };

 

 

ReportsEditor.MediaManager.ViewPaths =

new string[] { "~/Media" };

 

ReportsEditor.MediaManager.UploadPaths =

new string[] { "~/Media/New" };

 

ReportsEditor.MediaManager.MaxUploadFileSize = 2097151;

}

}


1 Answer, 1 is accepted

Sort by
0
Rumen
Telerik team
answered on 25 Mar 2010, 03:22 PM
Hi,

Do you experience this problem in Internet Explorer or in Firefox?

Please, note that Firefox is unable to play media and flash files in editable IFRAME / DIV elements and RadEditor just displays an image in the content area to mark that there is a video / flash object. Once the content is saved and displayed outside of RadEditor the video will be displayed.
This is not a bug of RadEditor but a not supported browser feature, which could be seen in all competitors' editors too.

If you experience this problem in Internet Explorer then try to load the video outside of the editor and see whether the browser is capable to play it. The video could be corrupted.

In addition try to reproduce the problem in the Default Example of RadEditor. Are you able to insert and play videos in the content area of RadEditor in this demo?

Best wishes,
Rumen
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
Tags
Editor
Asked by
avichal
Top achievements
Rank 1
Answers by
Rumen
Telerik team
Share this question
or