MakeUrlsAbsolute Error when using a secure domain and pasting in a non-secure URL

2 posts, 0 answers
  1. Brian Garson
    Brian Garson avatar
    54 posts
    Member since:
    Jan 2008

    Posted 20 Apr 2011 Link to this post

    Hello,

    I am having this issue with MakeUrlsAbsolute on the rad Editor in IE8.  Steps to reproduce:

    - create a page with a RadEditor and ContentFilters containing MakeUrlsAbsolute
    - visit your website under a secure domain: ie: https://telerik.com/MyPage.aspx using IE8http://www.google.ca/images/logos/ps_logo2.png
    - click on HTML view in the editor
    - paste testing <img src="http://www.google.ca/images/logos/ps_logo2.png"> testing
    - switch back to design view
    - when prompted with the IE8 "Do you want to view only the webpage content that was delivered securely?"   - select YES
    - it does not go back to design view
    - clicking on Design does nothing, clicking on HTML again will prompt the error: "Message from webpage    Error while executing filter MakeUrlsAbsolute - [object Error]

    thanks
  2. Rumen
    Admin
    Rumen avatar
    13804 posts

    Posted 22 Apr 2011 Link to this post

    Hi Brian,

    Thank you for reporting this problem. I logged it for fixing in our PITS system. The PITS issue is available at: Public URL.

    We do appreciate your bug report and help on improving RadEditor's content filters and I updated your Telerik points.

    Best regards,
    Rumen
    the Telerik team

    Browse the vast support resources we have to jump start your development with RadControls for ASP.NET AJAX. See how to integrate our AJAX controls seamlessly in SharePoint 2007/2010 visiting our common SharePoint portal.

Back to Top