Intelligent Labels - Broken?

Thread is closed for posting
3 posts, 0 answers
  1. Kevin Schneider
    Kevin Schneider avatar
    48 posts
    Member since:
    Jan 2008

    Posted 19 Aug 2009 Link to this post

    Hi,

    I'm trying to enable intelligent labels on my chart.  The X-Axis represents time (OA Date), the Y-Axis represents rate and features numbers in the 15000 - 40000 range.  I'm binding about 100 items to this chart.

    With intelligent labels toggled off the chart renders fine but the visible labels are out of control.  When I attempt to enable intelligent labels my ASPNET process skyrockets to 50-60% CPU and just sits there until the request times out.

    Any suggestions on what I can do to try and fix this?

    Telerik Version: 2009.1.527.35

    Thanks
  2. Velin
    Admin
    Velin avatar
    391 posts

    Posted 21 Aug 2009 Link to this post

    Hi Kevin,

    Unfortunately, the algorithm used by the "Intelligent labels" address scenarios with smaller number of items and  it is not suitable for more heavy weight scenarios like yours. This is the reason for the CPU overhead you have observed.

    We are sorry for the inconvenience.

    All the best,
    Velin
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. Kevin Schneider
    Kevin Schneider avatar
    48 posts
    Member since:
    Jan 2008

    Posted 21 Aug 2009 Link to this post

    I thought the whole point of intelligent labels was to reduce cluttering of numbers.  You get the most cluttering (unreadable) when there is a large number of points to be charted.  This feature seems pretty useless to me in its current implementation...
Back to Top