image manager page loaded but not buttons working

3 posts, 0 answers
  1. AUK
    AUK avatar
    47 posts
    Member since:
    Oct 2004

    Posted 30 Jun 2013 Link to this post

    Hi,

    Just upgraded radeditor to the latest version from an very old version (.net 1.1 site), now my site is running on .net 4.0, I have removed all the old telerik dll files and new rad editor seems working fine, I can edit/save the content, however, when I open the image manager from rad editor, image manager page is loaded, and the default folder in image manager is correct, I can see the sub-folders, but I can't see the (image) files, although it does say 'items 1 to 100 of 101', also none of the buttons is working on image manager page...

    any help would be appreciated!

  2. Ivaylo
    Admin
    Ivaylo avatar
    37 posts

    Posted 02 Jul 2013 Link to this post

    Hello,

    I have tried to reproduce the described scenario, but to no avail. I am afraid that I can only assume as to what the configuration of the controls is.

    Without any further information, I can only suggest checking if the ViewPaths of the ImageManager are properly configured (using slashes (/): '~/Folder1/SubFolder1') and if there are any errors that have been raised in the browser's console. Should you be using a custom content provider, may I ask you to verify if it is not the one causing the problem?

    Another possible reason for the issue to appear could be if you have customized the built-in Image Manager Dialog and have not updated it to match the control's version. It is very important that the used External Dialogs are from the same version as the control.

    Should none of the above suggestions result in the expected behavior, in order to further investigate the issue, could you, please, provide us with additional information regarding the browser in which the problem appears and its version? Also, is the latest version of the controls you are referring to 2013.2.611? It is of importance to know if you have implemented a custom content provider, as well. Should the problem persist, could I ask you to prepare a sample fully-runnable project, isolating the issue, so that we can further delve into the issue?
     
    Regards,
    Ivaylo
    Telerik
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to the blog feed now.
  3. AUK
    AUK avatar
    47 posts
    Member since:
    Oct 2004

    Posted 04 Jul 2013 Link to this post

    Hi, I forgot to mention that my project was upgraded from older .net website, and I have discovered that the problem is solved after I remove the following from web.config:

    • <xhtmlConformance mode="Legacy"/>



    many thanks for your help and I will try the narrow down the problem first next time!
Back to Top