Image Manager can't see .jpeg

3 posts, 0 answers
  1. david
    david avatar
    242 posts
    Member since:
    May 2007

    Posted 16 Dec 2013 Link to this post

    Within Radeditor, the imagemanager doesn't see .jpeg files when browsing.

    We have :
                string[] sImageSearchPatterns = new string[] { "*.png""*.gif""*.jpg" , "*.jpeg"};
    
       RadEditor1.ImageManager.SearchPatterns = sImageSearchPatterns;
    
  2. Shinu
    Shinu avatar
    17764 posts
    Member since:
    Mar 2007

    Posted 17 Dec 2013 Link to this post

    Hi david,

    Unfortunately I couldn't replicate the issue at my end. Please have a look into the sample code snippet which works fine at my end.

    ASPX:
    <telerik:RadEditor runat="server" ID="RadEditor1" Height="400px">
        <Tools>
            <telerik:EditorToolGroup Tag="FileManagers">
                <telerik:EditorTool Name="ImageManager"></telerik:EditorTool>
            </telerik:EditorToolGroup>
        </Tools>
        <ImageManager ViewPaths="~/Images/" />
    </telerik:RadEditor>

    C#:
    protected void Page_Load(object sender, EventArgs e)
    {
        string[] sImageSearchPatterns = new string[] { "*.jpeg","*.jpg" };
        RadEditor1.ImageManager.SearchPatterns = sImageSearchPatterns;
    }

    Please provide your full code if it doesn't help.
    Thanks,
    Shinu.
  3. david
    david avatar
    242 posts
    Member since:
    May 2007

    Posted 17 Dec 2013 Link to this post

    Thanks, my code works after all, sort of embarrassing. Turns out in lmage-manager the list view is sorted by extension, not by name so the .jpeg sorted to the bottom of a very long list and we didn't see them.

Back to Top