This is a migrated thread and some comments may be shown as answers.

Image manager and ResourceHandler.axd

7 Answers 159 Views
Editor
This is a migrated thread and some comments may be shown as answers.
Afendi Hamat
Top achievements
Rank 1
Afendi Hamat asked on 23 Apr 2010, 12:43 PM
hi all,

I have javascript error when i click on Image Manager button in rad editor. The image manager is 'locked' i.e the buttons for uploading etc are disabled.

it says:

Message: Object expected
Line: 1807
Char: 1
Code: 0
URI: http://localhost/rpcrim/Telerik.Web.UI.DialogHandler.axd?DialogName=ImageManager&Skin=Vista&Title=Image%20Manager&doid=a37566c0-64a9-4fac-a155-51cce0d578ed&dpptn=&dp=bSoZJR1lDT53C2NFSmJsDyAPA38KKytROGc0ewgbAQNiGyVTJmxbOVgQcUIqOh8JWgY%2FDhNoOx1sGRwtZn1nKxMrEzcHLgZoOncsZg8oGT9VQBMWKlN1G3QTMHYcFXACajl%2FbwgNCSd7G28GcX93CC8qHyUKPwpNJUwgRAYmO1pRfDEKHwtbFmMdEUMvPQMgXF8aJQpEJwdBInMZZBp3CS8QAz0KLTBSLXYCUg4nJxpQbHAfMHxpElsNDlwxFAggaSUFZx1pKwRBC10Dcn1zLS8fGyEzASRzF08wUhA0NBlibhspLwt5ImodLFwuFQ8jazo7NwlRM2RxIEE7eRoVTSJ2KjYJLgYQIk8sZAobRVthRy0sGW9hC2soLGcwBioraAYZORNRHQByGBVCfhh3FBUqByEFPxoWEGYwRz4eOBliYwNXJmpEDXUBNHofBwM9ZTgZPSZlDSRBJ38FSW13KBIQEyMxIDtVJkwgTT9CIBl5aDE%2FMQh5DGMDI0gcBDEeXV8BPiV6M2R7FHcFSRgULS8fGyEcPQZOFmkoUhA0NBl7GxMWHn5lOVooeQMeYhMqbl92IyN6CSdGCmcMSRl7DCwAHzcGMDBRLnRTVj4nIBlmRg8VHwtmCXQGNwcrPSk%2FW1wNPiN6NyhuCncMT310DzsEMRsCPWlqLU0CdDknIyNlRiUoHQhcSG4dMHsrYHQbawcZBhFHGTp0IlUiSEZNKyITHx0GSDATImYWeT0mLBJjQQ8HLm5bNWwDBQktBDEVWiUdOiRQajpACXcFcn1ZCix0Bx8JIA5JOGQ8Vj44OwZ4bwgVMwllD2ASCkMnBhc8Wzp%2BPyVQGSJACV0FSUdVDBQqKj0CFRpVFxMzTREJDT9XRR8KMwllD2ASCkMnBRMnZgAZPR16CTl3flEFSURsDyQqDz0zSglVOVgeaz8eIwZ7GhsKHn5lA1gSM0UvFyk7XSp2OBV6CT9DGxAFT21NChQufAsxLxpVFhMCazkoNwZgRg8SJmpLPWASOEonAzIkcysVHhFTETN1CVUCcnJKTSEBORYDIApxInYSDwkcETlXbBsuM2FfN1h0CkcqBiFnWwEgIRNTBTtAIG9AckBrSBMsMTwyMA58IhM0TQo2ES1QfSU%2BJn5LEFh0CkcqBiFnWwE%2FYyMPOwVwfX8PfEZJNxUAD3seLjRHIhEKDwocIxhXGyUhK1RLEFsudUckOgxjcDh%2BJxZlNxxzNndBf21RMhJ3cBoePB5oJRICUAkkOz1XGRsvKldfG28BBgEqPC0EcioBIhVTER9zfG8ncWxFNxV1DxYEEyRHI2YeaAUaP1pWbAMXMXFbNFguGkQqBiEFcl12ExVpFR10fFUaf35rLjsDPQMJL2lIEHYgUAYjDS1tfDEcJmpEDXUDMGgzGBcEaQZ%2FbwgNbjpHCnMCSW0YFCwCEz4yPwpyFXkWUhA1LwJWYwcKMH12CXQ%2FAUcwFAQkcikOaw%3D%3D
___
 and that particular line (1807) is empty

Sys.Application.add_init(function() { 
    $create(Telerik.Web.UI.RadContextMenu, {"_childListElementCssClass":null,"_skin":"Vista","clientStateFieldID":"RadFileExplorer1_tree_RadTreeViewContextMenu1_ClientState","collapseAnimation":"{\"duration\":450}","expandAnimation":"{\"duration\":450}","itemData":[{"value":"Delete","selectedCssClass":"rfeNoClass"},{"postBack":0,"value":"Rename","selectedCssClass":"rfeNoClass"},{"postBack":0,"value":"NewFolder","selectedCssClass":"rfeNoClass"},{"postBack":0,"value":"Upload","selectedCssClass":"rfeNoClass"}]}, null, null, $get("RadFileExplorer1_tree_RadTreeViewContextMenu1")); 
}); 
<----------Line 1807-----  
WebForm_InitCallback();Sys.Application.add_init(function() { 
    $create(Telerik.Web.UI.RadTreeView, {"_postBackOnEdit":true,"_postBackOnExpand":true,"_postBackReference":"__doPostBack(\u0027RadFileExplorer1$tree\u0027,\u0027arguments\u0027)","_selectedValue":"/rfolioassets/fendi/Documents","_skin":"Vista","_uniqueId":"RadFileExplorer1$tree","clientStateFieldID":"RadFileExplorer1_tree_ClientState","collapseAnimation":"{\"duration\":200}","contextMenuIDs":["RadTreeViewContextMenu1"],"enableDragAndDrop":true,"expandAnimation":"{\"duration\":200}","nodeData":[{"value":"/rfolioassets/fendi/Documents","text":"Documents","selected":1,"attributes":{"Name":"Documents","Path":"/rfolioassets/fendi/Documents","Permissions":"7","Location":"/rfolioassets/fendi/"}}],"selectedIndexes":["0"]}, null, null, $get("RadFileExplorer1_tree")); 
 



7 Answers, 1 is accepted

Sort by
0
Rumen
Telerik team
answered on 23 Apr 2010, 03:43 PM
Hi Afendi,

Have you modified the Image manager dialog? Do you use external dialog files taken from old installation along with a newer Telerik.Web.UI.dll?

Can you please try the solution in this KB article: rror: "Sys is not defined" in RadEditor dialogs?

If you are unable to solve the problem, please open a support ticket and send a sample working project that demonstrates the error. I will examine it and provide a solution.


Greetings,
Rumen
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
Afendi Hamat
Top achievements
Rank 1
answered on 23 Apr 2010, 10:11 PM
thanks for the reply Rumen,

No i didnt do any of that, and i have read the article on 'Sys undefined.

The problems started when I tried using System.Web.Routing, the results were quite bad until i added the *.axd to the routetable and instruct it to ignore routing for the file. Most of the javascript problems and Ajax not loaded were gone.

I will try starting a fresh project and see if it can be reproduced.
0
Rumen Jekov
Top achievements
Rank 1
answered on 24 Apr 2010, 09:29 PM
Hi,

Can you please try the suggestion discussed in point four in this KB article:

Error: Web.config registration missing! The Telerik dialogs require a HttpHandler registration in the web.config file.


http://www.telerik.com/support/kb/aspnet-ajax/editor/error-web-config-registration-missing-the-telerik-dialogs-require-a-httphandler-registration-in-the-web-config-file.aspx

If it does not help, please send a sample working project.

Kind regards,
Rumen
0
Mark
Top achievements
Rank 1
answered on 22 Jun 2010, 02:48 PM
Once we install the handlers in the web.config file, we now get the following error:

"The input is not a valid Base-64 string as it contains a non-base 64 character, more than two padding characters, or a non-white space character among the padding characters."

Are we missing something from the web.config that would cause this error?

Thanks,

Mark
Goolara, LLC
0
Dobromir
Telerik team
answered on 23 Jun 2010, 11:18 AM
Hi Mark,

Please find explanation and solution to this problem in the following help article:
Cannot Deserialize Dialog Parameters. Invalid character in a Base-64 string.

Greetings,
Dobromir
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
0
Mark
Top achievements
Rank 1
answered on 23 Jun 2010, 04:36 PM
Dobromir,

Thanks for your reply. However, the web.config entry mentioned in your referenced article is already a part of our web.config file. Here are our (relevant) web.config entries and our RadEditor for ASP.NET AJax code:

<

 

 

appSettings>

 

<

 

 

add key="Telerik.Web.UI.DialogParametersEncryptionKey" value="efertlkasjdfldsajflds1lsdjfo4354jlk"/>

 

[...]
</appSettings>

<

 

 

telerik:RadEditor runat="server" ID="RadEditor1"

 

 

 

Width="620px"

 

 

 

Height="660px"

 

 

 

ToolsFile="~/Config/ToolsFile.xml"

 

 

 

AllowScripts="True"

 

 

 

Skin="Web20" />

 


All help appreciated,

Mark
Goolara. LLC

0
Dobromir
Telerik team
answered on 24 Jun 2010, 04:12 PM
Hi Mark,

Could you please open a support ticket and provide a sample runnable project reproducing this problem so we can investigate it further?

Kind regards,
Dobromir
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Tags
Editor
Asked by
Afendi Hamat
Top achievements
Rank 1
Answers by
Rumen
Telerik team
Afendi Hamat
Top achievements
Rank 1
Rumen Jekov
Top achievements
Rank 1
Mark
Top achievements
Rank 1
Dobromir
Telerik team
Share this question
or