This is a migrated thread and some comments may be shown as answers.

Ignoring the grid filtering

2 Answers 26 Views
Grid
This is a migrated thread and some comments may be shown as answers.
Ahrensberg
Top achievements
Rank 1
Ahrensberg asked on 10 Nov 2009, 08:33 AM
Hi all,

I wan't to do the filtering on my radgrid manually, but do it by using the radgrid filtering controls. I grab the filter command in the OnItemCommand event, and doing afterwards the filtering on my datasource, but my radgrid also still sort on the datasource.

How can I set the radgrid not to do the sorting automatically. I believe that I have done something similar earlier by setting the MasterTableView.FilterExpressions = "", but it doesn't seems to work now (or at least I don't know where to set it, have tried in OnPreRender and OnNeedDataSource). I also found some forum threads telling that setting the EnableLinqExpressions to false should help, but seems not to help either.

What should I do?

EDIT: I'm using Telerik.Web.UI 2009.3.1103.35, maybe a bug in 2009 Q3?

2 Answers, 1 is accepted

Sort by
0
Accepted
Vlad
Telerik team
answered on 11 Nov 2009, 02:13 PM
Hi,

You may need to cancel desired command in ItemCommand - e.Cancel = true.

Best wishes,
Vlad
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
0
Ahrensberg
Top achievements
Rank 1
answered on 13 Nov 2009, 09:01 AM
Thank you, was exactly was I looked for! :o)
Tags
Grid
Asked by
Ahrensberg
Top achievements
Rank 1
Answers by
Vlad
Telerik team
Ahrensberg
Top achievements
Rank 1
Share this question
or