IE9 Beta breaks TreeView node expansion (2010 Q1)

2 posts, 1 answers
  1. JA
    JA avatar
    1 posts
    Member since:
    Jan 2010

    Posted 23 Sep 2010 Link to this post

    In the most recent IE9 Beta with 2010 Q1, the TreeView node expansion appears to not work, as you are not allowed to click the "plus" sign to expand the node.  It seems that the browser is not detecting it is a clickable area.  If you toggle into compatibility mode, the TreeView control works as expected.  Is this a known issue; can anyone else using the latest IE9 Beta confirm this issue?

    I have the issue both on my own site I'm working on as well as on all the Telerik demo sites.  None of these work: http://demos.telerik.com/aspnet-ajax/treeview/examples/programming/loadondemandmodes/defaultcs.aspx


    Jacob
  2. Answer
    Kamen Bundev
    Admin
    Kamen Bundev avatar
    1532 posts

    Posted 30 Sep 2010 Link to this post

    Hello Jacob,

    We were able to reproduce this issue in a plain HTML page and submitted a bug to Microsoft Connect about it. This is clearly a bug in the rendering of HTML elements with display: inline-block and as such we don't plan on fixing it until IE9 final is released. I'm attaching both test pages if you want to check them out.

    Kamen Bundev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Back to Top