How to Prevent RadDatePicker auto correct date

2 posts, 0 answers
  1. Murugesan Jambukesan
    Murugesan Jambukesan avatar
    13 posts
    Member since:
    Sep 2009

    Posted 27 Apr Link to this post

    Hi Team,

    We need to prevent auto correct for raddatepicker. such as client entered 04/31/2017 it is automatically changed as 05/01/2017. we dont want autocorrect. instead of we need to show warning. if i entered 04/32/2017 it is throw warning correctly. we dont want just script for fix this issue. In our application we are using more than 500 pages. we need to have the common fix. it is very urjent. Please help us ASAP.

     

    Thanks,

     

     

  2. Eyup
    Admin
    Eyup avatar
    3333 posts

    Posted 01 May Link to this post

    Hello,

    You can achieve this requirement using the following property:
    <telerik:RadDatePicker ID="RadDatePicker1" runat="server">
        <DateInput runat="server" EnableSmartParsing="false"></DateInput>
    </telerik:RadDatePicker>

    Generally, you can try using adapters to set the default settings for a control:
    http://www.telerik.com/forums/raddatepicker-remove-1-1-1980-mindate-default
    http://www.telerik.com/forums/hide-row-header-of-filter-raddatepicker


    I've also attached a sample web site for basic demonstration.
    I hope this will prove helpful.

    Regards,
    Eyup
    Telerik by Progress
    Try our brand new, jQuery-free Angular 2 components built from ground-up which deliver the business app essential building blocks - a grid component, data visualization (charts) and form elements.
Back to Top