How not to display the tallest bar label inside the bar?

Thread is closed for posting
2 posts, 0 answers
  1. Matthew Kwan
    Matthew Kwan avatar
    3 posts
    Member since:
    Oct 2009

    Posted 15 Jan 2010 Link to this post

    Hi,

    Please see attachment.

    The tallest bars with the figure label 1000 is displayed in the bar, how can I make it to show on Top of the bar (consistent with the rest).

    I know this is caused by the max Y-axis value.  I would like to achieve it by not setting Y-axis autoscale = false, minvalue = xxx, maxvalue = yyy and step = xxx. 

    Please advise.

    Regards,
    Matt

  2. Giuseppe
    Admin
    Giuseppe avatar
    2363 posts

    Posted 19 Jan 2010 Link to this post

    Hello Matthew Kwan,

    Generally there are two approaches for extending the YAxis range -- one is by manually setting the axis range (+ AutoScale=false), and the other is by setting the AxisY.AxisMode property to "Extended" (setting this property automatically extends the axis range by 1 step).

    However, I do not think that you will get the best result by setting the AxisMode property in your scenario (the step on your YAxis is rather small, and even when the axis is extended by 1 step, there probably will not be enough space above the bar for displaying the "1000" label vertically.  You will probably need to consider setting the axis range manually or displaying the item labels horizontally.


    Greetings,
    Manuel
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
Back to Top