This is a migrated thread and some comments may be shown as answers.

Filter Group Expressions

2 Answers 26 Views
Filter
This is a migrated thread and some comments may be shown as answers.
Rayne
Top achievements
Rank 1
Rayne asked on 19 Sep 2013, 02:50 PM
I have a RadFilter on my page and it isn't grouping properly.

When I first load the page, I'm creating a default filter expression for the associated grid. But if I then try to add a group expression, it's not grouping properly. I click the Add Group button and it creates the Group node. I then change the expression from And to Or. Then click to add an expression and when the expression is added, it's added to the top group, not the second one.

If I then remove the added expression and try again, it works and creates the expression where it is supposed to go. I've attached two images that show how it's grouping initially (wrong) and how it groups after removing the last expression and adding it again (right).

2 Answers, 1 is accepted

Sort by
0
Angel Petrov
Telerik team
answered on 24 Sep 2013, 08:48 AM
Hello Rayne,

Following the scenario I have assembled a sample website but was unable to reproduce the unwanted behavior. Could you please examine the attached test project and tell us what differs in your case? If you could modify it so that the problem is reproducible that would be great. Once we are able to replicate the issue we should be able to provide an appropriate solution.

Regards,
Angel Petrov
Telerik
If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to the blog feed now.
0
Rayne
Top achievements
Rank 1
answered on 24 Sep 2013, 01:08 PM
Apparently all that was needed was to update my controls to the latest version. Updating to version 2013.2.917.40 fixed the problem.
Tags
Filter
Asked by
Rayne
Top achievements
Rank 1
Answers by
Angel Petrov
Telerik team
Rayne
Top achievements
Rank 1
Share this question
or