Event Naming - A Suggestion

2 posts, 0 answers
  1. Dan
    Dan avatar
    739 posts
    Member since:
    Mar 2009

    Posted 26 Apr 2007 Link to this post

    There are a number of Server-side properties used for identifying functions to be called when client-side events are triggered; 'OnClientBeforeShow', 'OnClientBeforeHide', 'OnClientShow' and 'OnClientHide'.

    Can I suggest that, in keeping with similar events in the r.a.d.Controls suite, that the first 2 are renamed as 'OnClientShowing' and 'OnClientHiding'.

  2. Petya
    Petya avatar
    869 posts

    Posted 26 Apr 2007 Link to this post

    Hi Stuart Hemming,

    As the controls are still in Beta stage, naming convention is also under a slight testing. Of course in the future they will unify and most probably it will be to OnClientShowing rather than OnClientBeforeShow.

    Sincerely yours,
    the telerik team

    Instantly find answers to your questions at the new Telerik Support Center
Back to Top