Error while filtering in Telerik Grid with any word starting with symbol '?'.
1 Answer 20 Views
Shivani
Top achievements
Rank 1
Shivani asked on 11 May 2021, 02:38 PM

Hello Developers!

I am using Telerik Radgrid with Excel-like filters for creating my data grids. One issue I face is I cannot filter with symbol '?' or any word starting with '?' like '?check'. It immediately redirects to 500 internal error. If the symbol comes after any other character, the filter works fine, like 'o?c'.

I use RadGrid with DB source and autopopulate columns according to datasource. My filters are Excel-like filters.

I can replicate the same issue in your demo webpage for Excel-like filters too.

Placed screenshots for reference.

URL used: Telerik Web UI Grid Excel-like Filtering Demo | Telerik UI for ASP.NET AJAX

Could you let me know what can be done for this? It is absolutely important for me to be able to filter with '?'

Thanks and Regards

1 Answer, 1 is accepted

Sort by
0
Vessy
Telerik team
answered on 12 May 2021, 11:46 AM

Hi Shivani,

The Grid indeed has a set of predefined illegal characters which are not allowed, but the "?" sign is not among them. You can see the default behavior of its filtering in the video below:

http://somup.com/crhlXBF7ae

You can see the default set of illegal characters defined in the Grid here:

https://www.telerik.com/support/kb/aspnet-ajax/grid/details/filter-grid-with-quotes-and-or-or-other-special-symbols

Regards,
Vessy
Progress Telerik

Тhe web is about to get a bit better! 

The Progress Hack-For-Good Challenge has started. Learn how to enter and make the web a worthier place: https://progress-worthyweb.devpost.com.

Asked by
Shivani
Top achievements
Rank 1
Answers by
Vessy
Telerik team
Share this question
or