This is a migrated thread and some comments may be shown as answers.

Editor does not work or any control

8 Answers 60 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
David
Top achievements
Rank 1
David asked on 23 Nov 2011, 10:14 AM
I have just installed the latest demo of telerik rad controls and configured my project using right click configure telerik products and the ajax functionality of all controls does not work they appear and render fine but do not for example the datepicker does not drop down and none of the editor buttons fuction I have included a paste bin of my web.config to see what is wrong and also include an example of how I am implmenting 


http://pastebin.com/QBgBz4Hs



this is an example of my implementation

http://pastebin.com/pjarxYyR

8 Answers, 1 is accepted

Sort by
0
Rumen
Telerik team
answered on 25 Nov 2011, 09:06 AM
Hi David,

I tried to reproduce the problem using the provided web.config and aspx page but without success - here you can see a video demonstrating my test: http://screencast.com/t/2yJRuH4FoMd. For your convenience I have attached my test project. Please, test it and if you still experience the problem provide details of the JavaScript error that prevents the proper loading of the controls.

Best regards,
Rumen
the Telerik team
If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now
0
David
Top achievements
Rank 1
answered on 25 Nov 2011, 10:12 AM
With the exact same code in a style sheet and web config this is what I get displayed below. I no its not my style sheet as I have also created a form independendt to my masterpage all the dlls are correctly located including skins
0
Rumen
Telerik team
answered on 25 Nov 2011, 11:31 AM
Hi David,

The provided information is not enough to determine the exact reason for the problem.

Do you use a custom skin for RadControls or the built-in skins of the RadEditor and RadDatePicker are not loaded?
Do you get any error messages in the JavaScript error console?
Does the problem happen in Internet Explorer and Firefox?

Please, isolate the appearance issue in a sample working project and send it for examination via a support ticket.


Best wishes,
Rumen
the Telerik team
If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now
0
David
Top achievements
Rank 1
answered on 25 Nov 2011, 11:37 AM
I found the reason that for some reason the rad style sheets are not being loaded from your telerik web resource .xsd if you look at the attached image you will see the problem I believe this is why the controls are not rendering in my project any suggesions
0
David
Top achievements
Rank 1
answered on 25 Nov 2011, 12:57 PM
do you have a solution as to why your webresource is not work
0
Rumen
Telerik team
answered on 25 Nov 2011, 04:51 PM
Hi David,

It is not clear from the screenshot whether the error is 404 (file not found) for the Telerik.Web.UI.WebResource.axd resource file.

Could you please test the page in Internet Explorer with Fiddler or Firefox with Firebug and send a screenshot of the webresource error?
Did the other webresources of Telerik controls pass?
Does the problem happen only in this page?

I also noticed that you test your site under the built-in development server of Visual Studio. Is the problem
reproducible in IIS?

Could you please isolate the issue in a sample working project and send it for examination?

You can also try to research the problem yourself using the following useful resources:
Web Resources Troubleshooting,
RadScriptManager,
IIS7 and Telerik.Web.UI.WebResource.axd' is missing in web.config
and
General Troubleshooting.

Best regards,
Rumen
the Telerik team
If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now
0
David
Top achievements
Rank 1
answered on 30 Nov 2011, 04:54 PM
Sorry I was off for a few days here is the error from firebug

"NetworkError: 404 Not Found - http://localhost:49573/Account/modules/cms/js/libs/modernizr-2.0.6.min.js"
modern....min.js
"NetworkError: 404 Not Found - http://localhost:49573/Telerik.Web.UI.WebResource.axd?compress=1&_TSM_CombinedScripts_=%3b%3bTelerik.Web.UI%2c+Version%3d2011.3.1115.40%2c+Culture%3dneutral%2c+PublicKeyToken%3d121fae78165ba3d4%3aen-US%3acf16ab29-be3a-4761-9f9e-2c05ea68ff51%3ae59a902c%3bTelerik.Web.UI.Skins%2c+Version%3d2011.3.1115.40%2c+Culture%3dneutral%2c+PublicKeyToken%3d121fae78165ba3d4%3aen-US%3a285462cf-2c25-4a05-801f-e45b915bd1b6%3aac66bdd8%3bTelerik.Web.UI%2c+Version%3d2011.3.1115.40%2c+Culture%3dneutral%2c+PublicKeyToken%3d121fae78165ba3d4%3aen-US%3acf16ab29-be3a-4761-9f9e-2c05ea68ff51%3a92753c09%3bTelerik.Web.UI.Skins%2c+Version%3d2011.3.1115.40%2c+Culture%3dneutral%2c+PublicKeyToken%3d121fae78165ba3d4%3aen-US%3a285462cf-2c25-4a05-801f-e45b915bd1b6%3a311bfd78%3bTelerik.Web.UI%2c+Version%3d2011.3.1115.40%2c+Culture%3dneutral%2c+PublicKeyToken%3d121fae78165ba3d4%3aen-US%3acf16ab29-be3a-4761-9f9e-2c05ea68ff51%3aaac1aeb7%3bTelerik.Web.UI.Skins%2c+Version%3d2011.3.1115.40%2c+Culture%3dneutral%2c+PublicKeyToken%3d121fae78165ba3d4%3aen-US%3a285462cf-2c25-4a05-801f-e45b915bd1b6%3aa07539a3%3bTelerik.Web.UI%2c+Version%3d2011.3.1115.40%2c+Culture%3dneutral%2c+PublicKeyToken%3d121fae78165ba3d4%3aen-US%3acf16ab29-be3a-4761-9f9e-2c05ea68ff51%3ac86a4a06%3bTelerik.Web.UI.Skins%2c+Version%3d2011.3.1115.40%2c+Culture%3dneutral%2c+PublicKeyToken%3d121fae78165ba3d4%3aen-US%3a285462cf-2c25-4a05-801f-e45b915bd1b6%3a648927c0"
Teleri...48927c0
"NetworkError: 404 Not Found - http://localhost:49573/WebResource.axd?d=iL2Ghm8pdzYzqSLgWdlnq9d33UQ-Kt4BmCBjqtckaMj3vSZjHhJVXEkt5H-kaiTWbSu8w7QJ08xAX19NHKL1zgjEq8xSfTzSxyWoISXgLb41&t=634534317011483291"
WebRes...1483291
"NetworkError: 404 Not Found - http://localhost:49573/Scripts/System.Web.Extensions/4.0.0.0/4.0.30319.237/MicrosoftAjaxWebForms.js"
Micros...orms.js
"NetworkError: 404 Not Found - http://localhost:49573/Telerik.Web.UI.WebResource.axd?_TSM_HiddenField_=content_RadScriptManager2_TSM&compress=1&_TSM_CombinedScripts_=%3b%3bTelerik.Web.UI%3aen-US%3acf16ab29-be3a-4761-9f9e-2c05ea68ff51%3a16e4e7cd%3af7645509%3a22a6274a%3aed16cbdc%3a63b115ed%3a24ee1bba%3a874f8ea2%3a1569bb5f%3adc7e0bd%3a8547b8b2%3a30f1f089%3af46195d3%3a19620875%3a490a9d4e%3a7c926187%3a8674cba1%3ab7778d6c%3ac08e9f8a%3aa51ee93e%3a59462f1"
Teleri...59462f1
"NetworkError: 404 Not Found - http://localhost:49573/Account/modules/cms/js/libs/modernizr-2.0.6.min.js"
modern....min.js
"NetworkError: 404 Not Found - http://localhost:49573/Telerik.Web.UI.WebResource.axd?compress=1&_TSM_CombinedScripts_=%3b%3bTelerik.Web.UI%2c+Version%3d2011.3.1115.40%2c+Culture%3dneutral%2c+PublicKeyToken%3d121fae78165ba3d4%3aen-US%3acf16ab29-be3a-4761-9f9e-2c05ea68ff51%3ae59a902c%3bTelerik.Web.UI.Skins%2c+Version%3d2011.3.1115.40%2c+Culture%3dneutral%2c+PublicKeyToken%3d121fae78165ba3d4%3aen-US%3a285462cf-2c25-4a05-801f-e45b915bd1b6%3aac66bdd8%3bTelerik.Web.UI%2c+Version%3d2011.3.1115.40%2c+Culture%3dneutral%2c+PublicKeyToken%3d121fae78165ba3d4%3aen-US%3acf16ab29-be3a-4761-9f9e-2c05ea68ff51%3a92753c09%3bTelerik.Web.UI.Skins%2c+Version%3d2011.3.1115.40%2c+Culture%3dneutral%2c+PublicKeyToken%3d121fae78165ba3d4%3aen-US%3a285462cf-2c25-4a05-801f-e45b915bd1b6%3a311bfd78%3bTelerik.Web.UI%2c+Version%3d2011.3.1115.40%2c+Culture%3dneutral%2c+PublicKeyToken%3d121fae78165ba3d4%3aen-US%3acf16ab29-be3a-4761-9f9e-2c05ea68ff51%3aaac1aeb7%3bTelerik.Web.UI.Skins%2c+Version%3d2011.3.1115.40%2c+Culture%3dneutral%2c+PublicKeyToken%3d121fae78165ba3d4%3aen-US%3a285462cf-2c25-4a05-801f-e45b915bd1b6%3aa07539a3%3bTelerik.Web.UI%2c+Version%3d2011.3.1115.40%2c+Culture%3dneutral%2c+PublicKeyToken%3d121fae78165ba3d4%3aen-US%3acf16ab29-be3a-4761-9f9e-2c05ea68ff51%3ac86a4a06%3bTelerik.Web.UI.Skins%2c+Version%3d2011.3.1115.40%2c+Culture%3dneutral%2c+PublicKeyToken%3d121fae78165ba3d4%3aen-US%3a285462cf-2c25-4a05-801f-e45b915bd1b6%3a648927c0"
Teleri...48927c0
"NetworkError: 404 Not Found - http://localhost:49573/WebResource.axd?d=iL2Ghm8pdzYzqSLgWdlnq9d33UQ-Kt4BmCBjqtckaMj3vSZjHhJVXEkt5H-kaiTWbSu8w7QJ08xAX19NHKL1zgjEq8xSfTzSxyWoISXgLb41&t=634534317011483291"
WebRes...1483291
"NetworkError: 404 Not Found - http://localhost:49573/Telerik.Web.UI.WebResource.axd?_TSM_HiddenField_=content_RadScriptManager2_TSM&compress=1&_TSM_CombinedScripts_=%3b%3bTelerik.Web.UI%3aen-US%3acf16ab29-be3a-4761-9f9e-2c05ea68ff51%3a16e4e7cd%3af7645509%3a22a6274a%3aed16cbdc%3a63b115ed%3a24ee1bba%3a874f8ea2%3a1569bb5f%3adc7e0bd%3a8547b8b2%3a30f1f089%3af46195d3%3a19620875%3a490a9d4e%3a7c926187%3a8674cba1%3ab7778d6c%3ac08e9f8a%3aa51ee93e%3a59462f1"
Teleri...59462f1
"NetworkError: 404 Not Found - http://localhost:49573/Scripts/System.Web.Extensions/4.0.0.0/4.0.30319.237/MicrosoftAjaxWebForms.js"
Micros...orms.js
http://localhost:49573/Scripts/System.Web.Extensions/4.0.0.0/4.0.30319.237/MicrosoftAjaxWebForms.js"
0
Rumen
Telerik team
answered on 05 Dec 2011, 12:34 PM
Hi David,

The missing resources problem is due to non properly configured web application.
I examined the provided details in your last message and noticed that even non Telerik related resources are missing like the modernizr script:

http://localhost:49573/Account/modules/cms/js/libs/modernizr-2.0.6.min.js

My suggestion is to create a new Ajax enabled web application in Visual Studio, add the Telerik control and verify that they work as expected. After that compare the configuration files of both project until you find the reason for the 404 errors.

Best regards,
Rumen
the Telerik team
If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now
Tags
General Discussions
Asked by
David
Top achievements
Rank 1
Answers by
Rumen
Telerik team
David
Top achievements
Rank 1
David
Top achievements
Rank 1
Share this question
or