This is a migrated thread and some comments may be shown as answers.

Could not load file or assembly 'Telerik.Web.UI, Version=2010.3.1109.35

5 Answers 25 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
jegan
Top achievements
Rank 1
jegan asked on 09 Nov 2020, 01:32 PM

we have a SharePoint 2016 farm on premises with 2 WFE servers, we are now adding one more WFE server, hence we installed SP 2016 including latest cumulative updates in the new server, everything went fine till then, all the site collections which doesn't have any customizations are working fine. but, when we try to access a site collection which has customizations like left navigation and top ribbon with custom drop down values are giving the following error.

Could not load file or assembly 'Telerik.Web.UI, Version=2010.3.1109.35, Culture=neutral, PublicKeyToken=121fae78165ba3d4' or one of its dependencies. The system cannot find the file specified.

 

we are unable to fix this issue, hope you can guide us with the correct remediation steps to fix it. 

5 Answers, 1 is accepted

Sort by
0
Vessy
Telerik team
answered on 12 Nov 2020, 12:35 PM

Hi jegan,

The 2010 version of the suite does not support sp2013 since it wasn't available at the time of its creation and we do not have wsp installation for this server at that time. Thats why I assume that you are using the regular controls, but not the sharepoint web part we offer for SP2013 (that can be installed on sp2016 too), am I correct? If so,there are two possible options to resolve the error:
  • either to upgrade to a version which offers SP2013 support and to use our web parts
  • or to find out why the reference to Telerik.Web.UI is broken (e.g. missing SafeControl declaration(s), use of not fully qualified names for the handlers  and control directives, etc.)

Can you install the suite via the wsp which is located inside the Telerik_Web_Parts_For_Sharepoint2013_2020_3_1021_Trial.zip file and see if the problem persists? You can download it from your Telerik account here:
https://www.telerik.com/account/product-download?product=AJAX%20SP

Meanwhile, you can also take a look at the following thread:
https://social.technet.microsoft.com/Forums/en-US/e1668d41-8856-44f7-a3e2-0c573195844e/filenotfoundexception-could-not-load-file-or-assembly-telerikwebui-version2011291535?forum=sharepointadminprevious

Regards,
Vessy
Progress Telerik

Virtual Classroom, the free self-paced technical training that gets you up to speed with Telerik and Kendo UI products quickly just got a fresh new look + new and improved content including a brand new Blazor course! Check it out at https://learn.telerik.com/.

0
jegan
Top achievements
Rank 1
answered on 19 Nov 2020, 10:03 AM

Hi Vessy,

Thank you so much for replying. 

From your reply, i understood that in our SharePoint server we had used 2010 version of Telerik suite and now it is unsupported in our new server, since our system is built on SharePoint 2010 and later migrated to 2016 version.

So to solve that, your are suggesting us to to install the latest 2013 version of telerik suite in the new server to run the features.  is this correct  ?

 

Please help to understand you solution in a better way, so that i can use that to fix my issue. 

And to answer you next question, we are unable to find out why this telerik.web.ui is broken. 

 

0
Vessy
Telerik team
answered on 24 Nov 2020, 02:18 PM

Hi jegan,

Your assumption is almost correct. In order to fix the faced errors, we suggest that you install the latest TelerikĀ® Web Parts for SharePoint which supports both SharePoint 2013 and SharePoint 2016. You can download the installation file from your Telerik account here (you have to be logged in):

https://www.telerik.com/account/product-download?product=AJAX%20SP

You can find details on how to proceed with the installation here:

https://docs.telerik.com/devtools/aspnet-ajax/sharepoint/2013/installation-and-deployment/installing-telerik-web-parts

Regards,
Vessy
Progress Telerik

Virtual Classroom, the free self-paced technical training that gets you up to speed with Telerik and Kendo UI products quickly just got a fresh new look + new and improved content including a brand new Blazor course! Check it out at https://learn.telerik.com/.

0
jegan
Top achievements
Rank 1
answered on 27 Nov 2020, 08:49 AM

Hi Vessy,

 

Thank you so much, we will proceed with the given solution and try to fix the issue.

0
Vessy
Telerik team
answered on 27 Nov 2020, 08:54 AM

Hi,

You are welcome, Jega. Let us know in case any further issues with our controls occur during that process.

Regards,
Vessy
Progress Telerik

Virtual Classroom, the free self-paced technical training that gets you up to speed with Telerik and Kendo UI products quickly just got a fresh new look + new and improved content including a brand new Blazor course! Check it out at https://learn.telerik.com/.

Tags
General Discussions
Asked by
jegan
Top achievements
Rank 1
Answers by
Vessy
Telerik team
jegan
Top achievements
Rank 1
Share this question
or