ClientIdMode

6 posts, 0 answers
  1. Darin Beard
    Darin Beard avatar
    24 posts
    Member since:
    Dec 2004

    Posted 15 Jun 2010 Link to this post

    From the posts I've seen here I am gleaning that I cannot use ClientIdMode=Static and have the telerik tools working correctly... is that correct? I have a RadWindow that I am using as a controls container and it does not show any content in the window when the ClientIdMode=Static but if I remove that setting, the window shows the content. Is this going to be fixed or what can I expect? I am completely deflated right now because it is throwing a huge wrench into the current plan on this project.
  2. Fiko
    Admin
    Fiko avatar
    1406 posts

    Posted 18 Jun 2010 Link to this post

    Hello Darin,

    We are aware of such problem and we have already fixed it. The changes will be available in the upcoming release of the controls, but for the time being you can download the latest internal build where the changes are available as well.

    I hope this helps.

    All the best,
    Fiko
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Darin Beard
    Darin Beard avatar
    24 posts
    Member since:
    Dec 2004

    Posted 19 Jun 2010 Link to this post

    I just downloaded and tried the latest internal build and this is not fixed in it. As soon as I set clientidmode=static I get no content in the windows at all. 
  4. Rumen
    Admin
    Rumen avatar
    14351 posts

    Posted 21 Jun 2010 Link to this post

    Hi Darin,

    Please, excuse us for the misleading answer.

    The problem is not fixed in the latest internal build, but in the RadControls for ASP.NET AJAX Q2 2010 BETA that we are about to release this week.

    Best regards,
    Rumen
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. gunaah gunaah
    gunaah gunaah avatar
    3 posts
    Member since:
    Apr 2010

    Posted 20 Jul 2010 Link to this post

    This problem is still not fixed in q2 release. i have problem styling a raddock and radzone.

    Can anyone provide solution for this problem.

  6. Petio Petkov
    Admin
    Petio Petkov avatar
    825 posts

    Posted 23 Jul 2010 Link to this post

    Hi,

    The original problem in this thread is already fixed. Most of our controls are Naming Containers and expect their child controls to have certain IDs. We modified the base control classes (RadWebControl, RadDataBoundControl, etc.) and overrode the ClientIdMode property there (set it to AutoId)) and now everything works fine.

    In case that you have some styling issue, please open a new support thread and send us a runnable demo project where we can observe the issue. Once we receive it, we will do our best to help.

    Kind regards,
    Petio Petkov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Back to Top