This is a migrated thread and some comments may be shown as answers.

Cannot use a leading .. to exit above the top directory.

3 Answers 767 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Jack
Top achievements
Rank 1
Jack asked on 04 Apr 2013, 07:14 AM
Hii to Telerik Team. I am Facing a Problem.I have One System, In that my application is running on IIS.In IIs Under Default
web site i have two Links Test and Test1, On both same application is running.
Test Application is running fine but Test1 is not. I am getting error
[HttpException (0x80004005): Cannot use a leading .. to exit above the top directory.]
   System.Web.Util.UrlPath.ReduceVirtualPath(String path) +823
   System.Web.Util.UrlPath.Reduce(String path) +104
   System.Web.HttpResponse.ApplyAppPathModifier(String virtualPath) +232
   Telerik.Web.UI.RadGrid.InitializeGridTableViewData(GridTableView tableView) +5091
   Telerik.Web.UI.RadGrid.InitializeGridTableViewsRecursive(GridTableView tableView) +33
   Telerik.Web.UI.RadGrid.DescribeProperties(IScriptDescriptor descriptor) +2135
   Telerik.Web.UI.ScriptRegistrar.GetScriptDescriptors(Control control) +171
   Telerik.Web.UI.RadCompositeDataBoundControl.GetScriptDescriptors() +9
   System.Web.UI.ScriptControlManager.RegisterScriptDescriptors(IScriptControl scriptControl) +146
   Telerik.Web.UI.RadCompositeDataBoundControl.RegisterScriptDescriptors() +82
   Telerik.Web.UI.RadCompositeDataBoundControl.RenderContents(HtmlTextWriter writer) +50
   Telerik.Web.UI.GridBaseDataList.Render(HtmlTextWriter writer) +112
   Telerik.Web.UI.RadGrid.Render(HtmlTextWriter writer) +162
   Telerik.Web.UI.RadAjaxPanel.RenderChildren(HtmlTextWriter writer) +201
   System.Web.UI.WebControls.WebControl.RenderContents(HtmlTextWriter writer) +13
   Telerik.Web.UI.RadAjaxPanel.RenderContents(HtmlTextWriter writer) +31
   System.Web.UI.WebControls.WebControl.Render(HtmlTextWriter writer) +42
   Telerik.Web.UI.RadAjaxPanel.Render(HtmlTextWriter writer) +38
   Telerik.Web.UI.ControlRenderer.Render(HtmlTextWriter writer) +148
   System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) +246
   System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) +246
   System.Web.UI.UpdatePanel.RenderChildren(HtmlTextWriter writer) +294
   System.Web.UI.UpdatePanel.Render(HtmlTextWriter writer) +56
   Telerik.Web.UI.OurUpdatePanel.Render(HtmlTextWriter writer) +194
   Telerik.Web.UI.PreControlToAjaxify.Render(HtmlTextWriter writer) +193
   System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) +246
   System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) +246
   System.Web.UI.HtmlControls.HtmlContainerControl.Render(HtmlTextWriter writer) +42
   ASP.default_aspx.__RenderfrmFuse(HtmlTextWriter __w, Control parameterContainer) in g:\GIS\GTLERP2011\Default.aspx:95
   System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) +115
   System.Web.UI.HtmlControls.HtmlForm.RenderChildren(HtmlTextWriter writer) +256
   System.Web.UI.HtmlControls.HtmlForm.Render(HtmlTextWriter output) +324
   System.Web.UI.HtmlControls.HtmlForm.RenderControl(HtmlTextWriter writer) +73
   System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) +246
   System.Web.UI.Page.Render(HtmlTextWriter writer) +38
   GPS.GPSWeb._Default.Render(HtmlTextWriter writer) +67
   Telerik.Web.UI.RadAjaxControl.RenderPageInAjaxMode(HtmlTextWriter writer, Control page) +647
   System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) +115
   System.Web.UI.Page.Render(HtmlTextWriter writer) +38
   GPS.GPSWeb._Default.Render(HtmlTextWriter writer) +67
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +4428


Pls Help me as I am not getting that from where the error is coming.
same application is running fine on Test on same system but not Test1.


Solved



3 Answers, 1 is accepted

Sort by
0
Jack
Top achievements
Rank 1
answered on 04 Apr 2013, 07:33 AM
Ok I solved the Problem.Let me share so that it may help someone
i was calling webservice like
../WebService/webservice1.asmx"

I replace it by ~/WebService/webservice1.asmx"

Thats Worked for me

The page from where i am calling webservice was in Folder
 and webservice was also in a folder.
0
Gowtham
Top achievements
Rank 1
answered on 06 Jan 2015, 05:44 AM
thanks working fine
0
Marvin
Top achievements
Rank 1
answered on 06 Mar 2017, 11:00 AM
Working fine on SharePoint 2016, thanks!
Tags
General Discussions
Asked by
Jack
Top achievements
Rank 1
Answers by
Jack
Top achievements
Rank 1
Gowtham
Top achievements
Rank 1
Marvin
Top achievements
Rank 1
Share this question
or