can't set initialpath (inside formview)

2 posts, 0 answers
  1. SelAromDotNet
    SelAromDotNet avatar
    67 posts
    Member since:
    Jul 2012

    Posted 02 Jun 2009 Link to this post

    I have a radfileexplorer inside of a form view, which I want to use to select a thumbnail for a specific item. I can display the explorer, and it shows the appropriate folders, however, I cannot get it to set the initialpath. I've tried setting the property to "~/images/subfolder" and "/images/subfolder" and "/images/subfolder/" as well as putting the full uri to the folder...

    I noticed that in the online examples, this is set in the code behind on page load. However, since the explorer is in the form view, I cannot seem to find a way to reference it. I tried FindControls() but it always returns null...

    what is the correct way to do this?
  2. Fiko
    Fiko avatar
    1406 posts

    Posted 03 Jun 2009 Link to this post

    Hi SelArom,

    In the RadFileExplorer's declaration you need to set the full virtual path to the folder. For example, if you have website with root folder named WebRoot, then the initial path to a folder should be : /WebRoot/FileExplorerRoot/PathToFolder. For your convenience I have attached a demo to the thread.

    I hope this helps.

    All the best,
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
Back to Top