BUG: RadGrid Width Affected by Scaling

3 posts, 0 answers
  1. willk
    willk avatar
    18 posts
    Member since:
    May 2007

    Posted 02 Apr Link to this post

    Hi All,

    I have a monitor running at 125% scaling (set in Windows Display settings). The radgrid width is calculated incorrectly. For some reason I always get a grid that is 503px wide (100% would be about 1500).

    Both setting the scale to 100% and refreshing the page fixes it.

    Moving the window to another monitor at 100% scaling and refreshing fixes it.

     

    This looks to 100% be a bug in the way Telerik determines width when scaling is used.

    Thanks,

    Will

  2. Terri
    Terri avatar
    1 posts
    Member since:
    Apr 2019

    Posted 03 Apr in reply to willk Link to this post

    Yeah it is a bug..U should contact once officials.And see what they are telling..Regards myschoolbucks
  3. Attila Antal
    Admin
    Attila Antal avatar
    425 posts

    Posted 05 Apr Link to this post

    Hi Will,

    I have ran a quick test, and the Width of the grid is the same as is set in the markup in pixels, or if I set it to 100% percent, then I get a width of 1500px or so. In order to understand whether it is a bug, we will require some more details about the grid configuration. 

    Can this behavior be seen in our demos
    Could you test the sample project shared in the Update all, individual or selected rows using RadGrid with InPlace edit mode KB article and see whether the issue is still present?
    Could you describe the steps to replicate the problem?

    Kind regards,
    Attila Antal
    Progress Telerik
    Get quickly onboarded and successful with your Telerik and/or Kendo UI products with the Virtual Classroom free technical training, available to all active customers. Learn More.
Back to Top