blank image when upload image

4 posts, 0 answers
  1. Binh
    Binh avatar
    2 posts
    Member since:
    Nov 2012

    Posted 11 Apr 2013 Link to this post

    please help me ! When i upload my image to ImageManager , but i don't see my image, i just see a blank image. when i using imageeditor i see this image.
  2. Rumen
    Admin
    Rumen avatar
    13887 posts

    Posted 16 Apr 2013 Link to this post

    Hi,

    Are you able to reproduce the problem in the live demos of RadEditor? If the problem is not reproducible, please, upgrade to the latest Q1 2013 SP1 version 2013.1.403 of RadControls for ASP.NET AJAX.

    If the problem still persists after the upgrade, open a support ticket and provide a sample working project, which demonstrates the issue so that we can examine it and provide guidance how to solve it.

    Best regards,
    Rumen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  3. Binh
    Binh avatar
    2 posts
    Member since:
    Nov 2012

    Posted 16 Apr 2013 Link to this post

    i run example RadControls for ASP.NET AJAX Q2 2012 Live Examples , it's working. but i error with new website . My project:
    Code :
    <%@ Page Title="Home Page" Language="C#" MasterPageFile="~/Site.master" AutoEventWireup="true"
        CodeFile="Default.aspx.cs" Inherits="_Default" %>
     
    <%@ Register assembly="Telerik.Web.UI" namespace="Telerik.Web.UI" tagprefix="telerik" %>
     
    <asp:Content ID="HeaderContent" runat="server" ContentPlaceHolderID="HeadContent">
    </asp:Content>
     
    <asp:Content ID="BodyContent" runat="server" ContentPlaceHolderID="MainContent">
        <telerik:RadScriptManager ID="RadScriptManager1" runat="server">
    </telerik:RadScriptManager>
        <h2>
            Welcome to ASP.NET!
        </h2>
        <telerik:RadEditor ID="RadEditor1" Runat="server">
        <Tools>
        <telerik:EditorToolGroup Tag="FileManagers">
                        <telerik:EditorTool Name="ImageManager" />
                        <telerik:EditorTool Name="FlashManager" />
                        <telerik:EditorTool Name="MediaManager" />
                        <telerik:EditorTool Name="DocumentManager" />
                        <telerik:EditorTool Name="TemplateManager" />
        </telerik:EditorToolGroup>
        </Tools>
        <ImageManager ViewPaths="~/App_Data" UploadPaths="~/App_Data" ViewMode="Grid"/>
        </telerik:RadEditor>
        <p>
        </p>
        </asp:Content>


    Web.Config:

    <?xml version="1.0"?>
    <!--
      For more information on how to configure your ASP.NET application, please visit
      -->
    <configuration>
        <connectionStrings>
            <add name="ApplicationServices" connectionString="data source=.\SQLEXPRESS;Integrated Security=SSPI;AttachDBFilename=|DataDirectory|\aspnetdb.mdf;User Instance=true" providerName="System.Data.SqlClient"/>
        </connectionStrings>
        <system.web>
            <compilation debug="true" targetFramework="4.0">
                <assemblies>
                    <add assembly="System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
                    <add assembly="System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
                    <add assembly="System.Speech, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/></assemblies></compilation>
            <authentication mode="Forms">
                <forms loginUrl="~/Account/Login.aspx" timeout="2880"/>
            </authentication>
            <membership>
                <providers>
                    <clear/>
                    <add name="AspNetSqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider" connectionStringName="ApplicationServices" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="false" requiresUniqueEmail="false" maxInvalidPasswordAttempts="5" minRequiredPasswordLength="6" minRequiredNonalphanumericCharacters="0" passwordAttemptWindow="10" applicationName="/"/>
                </providers>
            </membership>
            <profile>
                <providers>
                    <clear/>
                    <add name="AspNetSqlProfileProvider" type="System.Web.Profile.SqlProfileProvider" connectionStringName="ApplicationServices" applicationName="/"/>
                </providers>
            </profile>
            <roleManager enabled="false">
                <providers>
                    <clear/>
                    <add name="AspNetSqlRoleProvider" type="System.Web.Security.SqlRoleProvider" connectionStringName="ApplicationServices" applicationName="/"/>
                    <add name="AspNetWindowsTokenRoleProvider" type="System.Web.Security.WindowsTokenRoleProvider" applicationName="/"/>
                </providers>
            </roleManager>
            <httpHandlers>
                <add path="ChartImage.axd" type="Telerik.Web.UI.ChartHttpHandler" verb="*" validate="false"/>
                <add verb="*" validate="false" path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler, Telerik.Web.UI"/>
                <add path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" verb="*" validate="false"/>
                <add path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler" verb="*" validate="false"/>
                <add path="Telerik.RadUploadProgressHandler.ashx" type="Telerik.Web.UI.RadUploadProgressHandler" verb="*" validate="false"/>
                <add path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" validate="false"/>
                <add verb="GET" path="CrystalImageHandler.aspx" type="CrystalDecisions.Web.CrystalImageHandler, CrystalDecisions.Web, Version=13.0.2000.0, Culture=neutral, PublicKeyToken=692fbea5521e1304"/>
            </httpHandlers>
        </system.web>
        <system.webServer>
            <modules runAllManagedModulesForAllRequests="true"/>
        </system.webServer>
    </configuration>

    Please help me !
  4. Rumen
    Admin
    Rumen avatar
    13887 posts

    Posted 18 Apr 2013 Link to this post

    Hello,

    Yesterday, we released Q1 2013 SP1 and my recommendation is to upgrade to it and test it.

    If the problem still persists, test with the attached sample web.config file and if it fixes the problem compare the settings in it with these in your web.config file.

    Test also by setting the ViewPaths and UploadPaths to ~/

    <ImageManager ViewPaths="~/" UploadPaths="~/" ViewMode="Grid"/>

    All the best,
    Rumen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
Back to Top