This is a migrated thread and some comments may be shown as answers.

Are these bugs fixed yet?????

3 Answers 40 Views
Editor
This is a migrated thread and some comments may be shown as answers.
greg gilmore
Top achievements
Rank 1
greg gilmore asked on 03 Nov 2010, 03:14 PM

'Cursor jumps to top of the text edito' (http://www.telerik.com/community/forums/sharepoint-2007/full-featured-editor/cursor-jumps-to-top-of-the-text-edito.aspx)   

and 'Upgrade messes up html'  (http://www.telerik.com/community/forums/aspnet-ajax/editor/upgrade-messes-up-html.aspx)  middle of page

I am having the same problem and would like to know if this has been fixed.  If so we will upgrade our package. 

I have a client whose .net app contains the editor complaining about this issue.

Thanks

3 Answers, 1 is accepted

Sort by
0
Stanimir
Telerik team
answered on 05 Nov 2010, 09:31 AM
Hello Greg,

The first problem is not fixed yet. However you can avoid it if you set the ToolbarMode property to Default or Floating. In order to do this modify the respective ConfigFile.xml or ListConfigFile.xml, which are located in the
/Program Files/Common Files/Microsoft Shared/web server extensions/wpresources/RadEditorSharePoint/5.x.x.0__1f131a624888eeed/Resources/ folder. Make sure that you have the following line:
<property name="ToolbarMode">Default</property>
or
<property name="ToolbarMode">Floating</property>

Regarding the second problem the reason for appearing of additional P elements is that initially the content was not XHTML compliant. When the editor tries to fix it these extra tags appear. We intend to fix the adding of extra P elements in one of the service packs of the next 2010.Q3 release. In mean time what you can do is turn off the ConvertToXhtml content filter. Review the following online help articles: http://www.telerik.com/help/aspnet-ajax/set-properties-via-config-file.htmlhttp://www.telerik.com/help/aspnet-ajax/contentfilters.html

Greetings,
Stanimir
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
0
greg gilmore
Top achievements
Rank 1
answered on 05 Nov 2010, 01:26 PM
Thanks for the reply Stanimir, You guys are great about customer service!

I have tried setting the toolbar mode to all the available settings in the property window of VS but it still does the same thing - in a long editor page when i click on empty space in the bottom part of the editor (where the browser window has scrolled down)  it 'jumps' or scrolls up.  Only when the cursor turns to a crosshair when hovering over an element will it not jump when clicked.  I'm assuming this is the same problem as other people are having?  My client is worse off.  He says his browser does it all the time no matter where he clicks so I thought maybe a browser setting?  I can't think of anything that would change that though...

Thanks again

Greg Gilmore
0
Stanimir
Telerik team
answered on 10 Nov 2010, 01:48 PM
Hi greg,

Unfortunately the bugs are not fixed yet. I increased the priority of the logs in our bug-tracking system, so I hope that the bugs will be fixed for the SP1 of the 2010.Q3 version of RadEditor.


Regards,
Stanimir
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Tags
Editor
Asked by
greg gilmore
Top achievements
Rank 1
Answers by
Stanimir
Telerik team
greg gilmore
Top achievements
Rank 1
Share this question
or