This is a migrated thread and some comments may be shown as answers.

Applying Skin from Q3 2008 to RadGrid

2 Answers 42 Views
Grid
This is a migrated thread and some comments may be shown as answers.
Zafar
Top achievements
Rank 1
Zafar asked on 19 May 2010, 08:14 PM
Hello,
I am using Q3 2008 versions of RadControls and and now trying to upgrade them to the newer version. I am using Vista skin for RadGrid and after the upgrade, it is not looking the same. To keep the same look, I am trying to use custom skins which I have downloaded from this forum. Using the instructions from this forum, I have been able to do this successfully for some controls like RadMenu and RadPanelBar but having trouble with the RadGrid. I am not very good at skins and CSS stuff but one thing I have noted is that other controls have two files like Menu.css and Menu.Vista.css but for Grid control I only see the Grid.Vista.css but don't see the Grid.css. Could this be the reason?

Also I have noted that when the grid don't have any rows then it seems that the old Vista skin is applied but when there are some rows then it does not show the old look. Any idea what I might be missing here?

Here is the forum I downloaded the skins and used instructions from

http://www.telerik.com/community/forums/aspnet-ajax/general-discussions/all-radcontrols-q3-2008-skins-are-now-compatible-with-the-q1-2009-release.aspx

Your help in this regard is much appreciated.

Thanks,

Zafar

2 Answers, 1 is accepted

Sort by
0
Dimo
Telerik team
answered on 20 May 2010, 11:43 AM
Hi Zafar,

RadGrid has a base stylesheet as of Q1 2010, that's why there is no such file in the ZIP, which you have downloaded from the forum thread.

Since the base stylesheet is an embedded CSS file and is registered after your custom skin, it may override some styles from the custom skin. To avoid this, please increase the specificity of your custom skin styles by adding a "div" in front of every ".RadGrid_Vista" class. I am attaching a simple demo, which works as expected.

>> "Also I have noted that when the grid don't have any rows then it seems that the old Vista skin is applied but when there are some rows then it does not show the old look. Any idea what I might be missing here?"

I am not sure why this would happen, please provide a demo.

Regards,
Dimo
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
Zafar
Top achievements
Rank 1
answered on 20 May 2010, 10:53 PM
Thank you very much Dimo for your great help!

Replacing the Grid.Vista.css file with the one from your demo fixed it for me. I am wondering if this is the file which should have been in the original download as the other won't work and will be overriden by the embeded CSS file.

Anyway, once again, thank you very much for your help with this as I could not have figured it out myself.

Thanks,

Zafar
Tags
Grid
Asked by
Zafar
Top achievements
Rank 1
Answers by
Dimo
Telerik team
Zafar
Top achievements
Rank 1
Share this question
or