This is a migrated thread and some comments may be shown as answers.

Allowing scripts when adding a custom colour

3 Answers 16 Views
Editor
This is a migrated thread and some comments may be shown as answers.
Roger Withnell
Top achievements
Rank 1
Roger Withnell asked on 17 Jun 2010, 01:03 AM
The Editor opens in a new window in my application so I "always allow popups for this website" in Internet Explorer.

When in the editor, I want to set the background of a table with a custonm colour. In the Table Wizard, I click Background colour and then Add Custom Colour.  Even though I have already allowed popups for this site permanently, IE says "this website is using a scripted window to ask you for information.  If you trust this website, click here to allow scripted windows..."  On clicking this, I only get the option to "Temporarily allow scripted Windows".  Therefore, every time I use Add Custom Color I have to go throught this procedure which is very tedious.

How can I set it to allow scripted windows for this action permanently on this website?

Your help would be much appreciated.

Thanking you in anticipation.

Roger

3 Answers, 1 is accepted

Sort by
0
Dobromir
Telerik team
answered on 18 Jun 2010, 04:04 PM
Hi Roger,

This is an expected browser behavior. By design, the AddCustomColor dialog that is opened is a standard Prompt dialog which is detected by Internet Explorer as possible harmful scripting.

A possible workaround for this behavior is overriding the default window.prompt command with radprompt, but it is not recommended.

Greetings,
Dobromir
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
0
Roger Withnell
Top achievements
Rank 1
answered on 19 Jun 2010, 12:11 AM
Thanks for your reply, Dobromir.

I can overcome it by setting Internet Explorer as a Trusted Site in Internet Options > Security.

The security level is set at Medium, the default.

Would you recommend this?

Many thanks.

Roger
0
Dobromir
Telerik team
answered on 21 Jun 2010, 01:07 PM

Yes Roger, it is another possible workaround for this behavior. If you are able to do so, this is the better approach.


Sincerely yours,
Dobromir
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Tags
Editor
Asked by
Roger Withnell
Top achievements
Rank 1
Answers by
Dobromir
Telerik team
Roger Withnell
Top achievements
Rank 1
Share this question
or