This is a migrated thread and some comments may be shown as answers.

AllowCustomText and MarkFirstMatch don't work in IE9

5 Answers 89 Views
ComboBox
This is a migrated thread and some comments may be shown as answers.
tomekm
Top achievements
Rank 1
tomekm asked on 24 May 2011, 12:48 PM

I use 2010.1.519.40 version of Rad Controls for ASP.NET AJAX

My RadComboBox uses markfirstmatch="true and allowcustomtext="true"

Here is code snippet:

<telerik:RadComboBox ID="RadComboBox1" runat="server" AllowCustomText="True" MarkFirstMatch="True"
  DataSourceID="LinqDataSource1" DataTextField="Name" DataValueField="Id">
</telerik:RadComboBox>

It does not work in IE9.

Autocomplete does not work at all and when I type custom text into control, on postback previously selected is set and RadComboBox1.Text on server side is set to that item.

Is there any fix/workaround?

5 Answers, 1 is accepted

Sort by
0
Shinu
Top achievements
Rank 1
answered on 24 May 2011, 01:31 PM
Hello Rychu,

IE 9, FireFox 4 and Google Chrome10 are supported by Telerik controls starting Q1 2011. So I suggest you to migrate to the new version. With older versions these browsers are only partially supported and the new features/enhancements or bugfixes merely for new versions of our AJAX components.

Thanks,
Shinu.
0
Sompop
Top achievements
Rank 1
answered on 29 Nov 2011, 04:38 PM
Hi Shinu and Team,

I know that you mentioned that Telerik will support since 2011 Q1. However, the latest version of .Net 2.0 is 2010 Q3 SP2. My issue is probably similar or the same. There is not much problem with IE8; however, with IE9, I have to use compatibility view in order for the "AllowCustomText" to work as expected. If not click compatibility view on IE9, when users type something not in the list, it will go back to the previous selected item on the list. If there is a workaround or some code to put, please let me know. Or if the latest version of .Net 2.0 is later than 2010 Q3 SP2 and it fixes this problem, please let me know as well.

<telerik:RadComboBox ID="rcbModel" runat="server" DataSourceID="SQLDS_Model" Skin="Default"
AutoPostBack="False" MarkFirstMatch="True" DataValueField="model" DataTextField="model" AllowCustomText="true" />

Thank you,
0
Helen
Telerik team
answered on 01 Dec 2011, 10:35 AM
Hello,

You have two options:

1. Force the page to open in Compatibility View.
2. You may build the source code of some of the latest versions(Q1 20011 and later) against .net2.0.


Regards,
Helen
the Telerik team
If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now
0
Sompop
Top achievements
Rank 1
answered on 06 Dec 2011, 12:02 AM
It actually works to force to open the page in compatibility view mode by taking out of the doctype tag. However, the css on my app is acting weird now.

I guess I have to find some other ways to achieve this.

Thank you,

0
Dimitar Terziev
Telerik team
answered on 08 Dec 2011, 05:33 PM
Hi Sompop,

My suggestion is try the second option and build a .NET 2.0 dll from the source code, as my colleague had suggested.

On how to force the page to open in compatibility view, please refer to the following help document.

Greetings,
Dimitar Terziev
the Telerik team
If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now
Tags
ComboBox
Asked by
tomekm
Top achievements
Rank 1
Answers by
Shinu
Top achievements
Rank 1
Sompop
Top achievements
Rank 1
Helen
Telerik team
Dimitar Terziev
Telerik team
Share this question
or