All my ComboBoxes have Scrollbars

10 posts, 0 answers
  1. Stuart Hemming
    Stuart Hemming avatar
    1622 posts
    Member since:
    Jul 2004

    Posted 06 Aug 2010 Link to this post

    For some reason, all the comboboxes in my app have vertical scrollbars, event if there are only one or 2 options. And I do mean "all"; even scrollbars in controls that I don't directly control like the Grid Pager (see attached).

    Why is this and how can I stop it from happening.

    I am not, to the very best of my knowledge, either doing anything to calculate/set the scroller height or to change the skin (I'm using the built in skin "WebBlue" FWIW).

    -- 
    Stuart
  2. Cori
    Cori avatar
    562 posts
    Member since:
    Jul 2010

    Posted 06 Aug 2010 Link to this post

    Are you using the RadFormDecorator control on your page? In your screenshot it looks like the scrollbar is being decorated. Perhaps that it the problem.
  3. Stuart Hemming
    Stuart Hemming avatar
    1622 posts
    Member since:
    Jul 2004

    Posted 06 Aug 2010 Link to this post

    Cori,

    You're correct; I do have a FormDecorator on the page, so maybe that is the question. But what is the answer? That's the real question! :-)

    -- 
    Stuart
  4. Cori
    Cori avatar
    562 posts
    Member since:
    Jul 2010

    Posted 06 Aug 2010 Link to this post

    Maybe you should exclude scroll bars from being decorated.
  5. Stuart Hemming
    Stuart Hemming avatar
    1622 posts
    Member since:
    Jul 2004

    Posted 06 Aug 2010 Link to this post

    I don't like that as an answer.

    And I've just created a standalone page with FormDecorator and ComboBox and there were no scroll bars!

    -- 
    Stuart
  6. Stuart Hemming
    Stuart Hemming avatar
    1622 posts
    Member since:
    Jul 2004

    Posted 09 Aug 2010 Link to this post

    Although I didn't like Cori's answer, I have tried it and disabling decoration of the scrollbars by RadFormDecorator makes no difference.

    -- 
    Stuart
  7. Yana
    Admin
    Yana avatar
    4813 posts

    Posted 10 Aug 2010 Link to this post

    Hello Stuart,

    Could you please send us a live url where we can observe this issue?  The provided information is not enough for us to reproduce it.

    Kind regards,
    Yana
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  8. Stuart Hemming
    Stuart Hemming avatar
    1622 posts
    Member since:
    Jul 2004

    Posted 10 Aug 2010 Link to this post

    Yana,

    Sadly I can't; the website has restricted access.

    I'll try and put together a standalone sample.

    -- 
    Stuart
  9. Yana
    Admin
    Yana avatar
    4813 posts

    Posted 10 Aug 2010 Link to this post

    Hello Stuart,

    It will really help resolve the issue. Thank you in advance

    Best regards,
    Yana
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  10. Stuart Hemming
    Stuart Hemming avatar
    1622 posts
    Member since:
    Jul 2004

    Posted 12 Aug 2010 Link to this post

    Yana,

    This problem has gone away, it turns out that it was due to the fact that IE was zoomed to 105%!

    -- 
    Stuart
Back to Top