Ajax not working when a grid is added

3 posts, 0 answers
  1. Paul
    Paul avatar
    35 posts
    Member since:
    Jul 2008

    Posted 07 Sep 2009 Link to this post

    Hi,

    I am trying to implement the example of inserting into a grid using a radwindow but im having problems calling the ajax request on the ajax manager.  It can find the ajax manager using the javascript (used an alert to confirm the variable) but when the request method is called I get the following error:

    Microsoft JScript runtime error: Sys.WebForms.PageRequestManagerServerErrorException: Index was out of range. Must be non-negative and less than the size of the collection.
    Parameter name: index





    to try and find my actual issue I took all the elements off the page and put a breakpoint on the ajax request (server side) even and a button to all it.  With no controls on the page it hit the breakpoint, with the radwindowmanager on it still hit the breakpoint but when the radgrid was added I got the same error and the breakpoint was not hit. so tried on a new page with new controls and still get the same error

    Thanks
  2. Georgi Tunev
    Admin
    Georgi Tunev avatar
    7207 posts

    Posted 08 Sep 2009 Link to this post

    Hello Paul,

    To be able to help we need to have a better view over your exact setup and the logic that you are using. Please open a support ticket and send us a sample project that shows your implementation and the error itself - we will check it right away.


    Best wishes,
    Georgi Tunev
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. Paul
    Paul avatar
    35 posts
    Member since:
    Jul 2008

    Posted 08 Sep 2009 Link to this post

    I have just solved it,

    I changed the grid from being created in the code behine to creating it in the HTML I cannot see any difference in the definition of the grid (as I just copied the code used to create it in the code behine) but it now works

    sorry to waste anyones time
Back to Top