An Installation Error Screen Appears during Installation
Environment
Product | Progress® Telerik® UI for ASP.NET AJAX |
Description
When installing Telerik UI or ASP.NET AJAX, an installation error screen appears.
Cause
The installer has encountered an unexpected error during the execution. The error may be caused by a circumstance on the particular machine.
Solution
Run the installation with logging enabled and send the log file in a support ticket for analysis. The log file will help the Support team to faster detect the problem. You'll either get a suggestion on how to fix the problem, or the installer will be fixed.
To start the installer with logging enabled:
-
Open a command prompt.
-
Navigate to the folder where the Telerik UI for ASP.NET AJAX installer is located.
-
Run the
msiexec /i [ControlsInstallation.msiFileName] /limev Telerik.Web.UI.Install.log
command.
Identified Occurrences
Based on similar issues, the identified occurrences include the following cases:
-
The Visual Studio reset performed by the installer did not succeed. On some machines the
[VSInstallDir]\Common7\IDE\devenv.exe /setup
command fails when called by the installer while it might not fail when you run the command directly from the command line.To avoid this issue, use any of the suggested approaches:
-
Delete all files in
[VSInstallDir]\Common7\IDE\ProjectTemplatesCache
. -
Delete all files in
[VSInstallDir]\Common7\IDE\ItemTemplatesCache
. -
Start a Visual Studio instance and run the installer without closing it.
-
Run the
[VSInstallDir]\Common7\IDE\devenv.exe /setup
command manually.
-
-
The automatic installation of ASP.NET AJAX Extensions 1.0, performed by the Telerik UI for ASP.NET AJAX installer as a prerequisite for the .NE 2.0 assemblies, did not succeed.
To work around this issue:
-
Download ASP.NET AJAX 1.0 and install it manually.
-
Run the Telerik UI for ASP.NET AJAX installer.
-
For more information, refer to the article on post-installation issues.