This is a migrated thread and some comments may be shown as answers.

VPN Connectivity Problem

3 Answers 90 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Farrukh
Top achievements
Rank 1
Farrukh asked on 14 Jun 2010, 08:13 AM


 

 We are using telerik Q1 2009 Licensed version ASP.NET AJAX Control  .The problem we are facing  is   when we deploy the website on SSL VPN port 443 using (VPN-DES and VPN-3DES-AES) encryption and we try to open the application then all  the  terlerik controls are not working 

1) The Rad Panel did not expand 

2) The Radcombobox appears disabled .Does not show data on combo box and when we click it does not do anything.

3) The   Rad date picker does not work. 

 

 But when we used asp.net control instead or telerik its working fine  . All controls like the  dropdownlist , grid view everything is working fine  .

 

Our application is fully ready to be deployed. We need to fix this integration issue of telerik controls through SSL VPN on HTTPS.

We need your assistance to fix this problem urgently. It is a bad option for us to redevelop  the full application with asp.net controls  instead of  using  telerik  controls. 

 

Note: LAN environment application working fine with telerik controls only problem when we access this application through SSL VPN on HTTPS

I have attached two files which will show the application behaviour in both environment Lan and VPN.

3 Answers, 1 is accepted

Sort by
0
Lini
Telerik team
answered on 15 Jun 2010, 08:46 AM
Hello,

We have had similar reports in the past about Cisco WebVPN. Here is a thread from our forums, discussing the issue - http://www.telerik.com/community/forums/sharepoint-2007/lite-editor-for-moss/rad-editor-not-working-for-web-vpn.aspx. Our controls offer an array of client-side (browser) features, that are implemented with JavaScript. The built-in ASP.NET controls do not have any of these features, so they are not affected by the WebVPN software overwriting the JavaScript with its own routines. Please try the suggested solution (enabling Smart Tunnel) and see if it helps.

Best wishes,
Lini
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
Farrukh
Top achievements
Rank 1
answered on 20 Jun 2010, 06:01 AM
We tried Smart tunnel option but same result all telerik controls was not working.
0
Lini
Telerik team
answered on 21 Jun 2010, 10:49 AM
Hi,

Did the URL in the browser change after you enabled the smart tunnel? It should no longer have the /+CSCO+..../ part in it. Unfortunately, we have no further information about this particular firewall, so I would recommend that you contact Cisco (if you have not done so already) and open a ticket with them about this issue.

Greetings,
Lini
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Tags
General Discussions
Asked by
Farrukh
Top achievements
Rank 1
Answers by
Lini
Telerik team
Farrukh
Top achievements
Rank 1
Share this question
or