Upgrade warnings and run-time errors...

2 posts, 0 answers
  1. Lynn
    Lynn avatar
    186 posts
    Member since:
    Sep 2006

    Posted 14 Jun 2016 Link to this post

    I have a large VS2013 ASP.NET/web forms solution that contains 2 references to my own .dll's that also have references to Telerik AJAX controls.  All was running fine, then...

    (1) I moved the entire solution to a new folder and opened the project in VS2015.

    (2) I upgraded the primary solution Telerik AJAX controls to the latest version (2016.2........).  The upgrade report gave me warnings about eight (8) Telerik assemblies ("Assembly reference "..................." was not updated properly.  This usually happens when an assembly exists both in the GAC and in a local folder.  Please use the GAC reference instead."

    (3) When I compile the solution, it compiles fine.

    (4) When I run the solution under Visual Studio in debug mode, I receive an error "Could not load file or assembly 'Telerik.Web.UI, Version=2015.2.623.45, ..................." or one of its dependencies.  The located assembly's manifest definition does not match the assembly reference...".

    My question is obviously......how do I fix this situation now?  I used the "Telerik UI for ASP.NET AJAX Upgrade Wizard" to upgrade my solution.  I have also loaded the other two .dll solutions that my primary solution is dependent upon, upgraded those Telerik AJAX controls, received the same warnings from the 'upgrade wizard' (and I use the term very loosely here), compiled them cleanly, and then re-compiled my main solution -- and received the same error during execution.

    I have read several forum entries on the Telerik site, including a dissertation on "Working with Assemblies in the GAC" by Marin Bratanov.  There is a lot of information available regarding this issue, but no actual directions as to how to get out of this "hole" that has been dug for me by your upgrade wizard.

    There are currently ninety-one (91) Telerik members in my GAC on my development system (Windows 10, Visual Studio 2012, Visual Studio 2013, Visual Studio 2015).  What steps can I take/do I need to take to eliminate this problem?  Delete all 91 members from the GAC?  Removed all sixteen (16) items from the "bin" folder of my solution(s)?  Or...............................

    Waiting on your response to be able to move forward.  Right now I cannot test a single thing in this large, critical web app solution.


  2. Dyanko
    Dyanko avatar
    133 posts

    Posted 15 Jun 2016 Link to this post

    Hello Lynn,

    Thank you for contacting us.

    I would recommend to keep our communication in the support thread already opened in order to get better response time and priority support.

    Do you need help with upgrading your ASP.NET AJAX, WPF or WinForms projects? Check the Telerik API Analyzer and share your thoughts.
Back to Top