Sample MAUI project in the download pkg is throwing error on buid.

1 Answer 191 Views
General Discussions
Shruti
Top achievements
Rank 1
Shruti asked on 14 Oct 2021, 12:00 AM | edited on 14 Oct 2021, 05:44 PM
Hi,

I am following the online documentation of TelerikUI to run the example SDK project with VS 2022. However, the build is throwing an error. Can someone please help with how to resolve this issue?

Shruti
Top achievements
Rank 1
commented on 14 Oct 2021, 06:25 PM | edited

I manage to resolve the above error but getting another error now. I tried using Telerik with a demo MAUI project as well but still getting the same error. Any help is much appreciated.


Lance | Manager Technical Support
Telerik team
commented on 14 Oct 2021, 06:50 PM

That error code is unrelated to Telerik controls. the missing class is MauiAppBuilder, which comes from Microsoft.

Please keep in mind that if you're trying to use .NET6 RC2 (released 2 days ago), this is not fully supported in the release of Telerik  because the latest release of Telerik UI for MAUI was built on .NET 6 RC1.

This is just a side effect of prerelease software, sometimes you may need to wait a few days for the different prerelease parts to line up. Our next release of UI for MAUI will have .NET 6 RC2 support, this will be coming as soon as possible.

1 Answer, 1 is accepted

Sort by
0
Accepted
Lance | Manager Technical Support
Telerik team
answered on 14 Oct 2021, 06:56 PM

Hi Shruti,

I'm replying again as answer because I have confirmed with a couple tests that if you try to use Telerik UI for Maui built for .NET 6 RC1 on a PC that is using .NET 6 RC2, you will get the reported issues.

The only solutions here are:

  • Downgrade your machine to RC1 (I do not recommend this)
  • Wait for the next release of Telerik UI for MAUI

I can't give you an exact time of the next preview release, but it should be soon.

Regards,
Lance | Manager Technical Support
Progress Telerik

Remote troubleshooting is now easier with Telerik Fiddler Jam. Get the full context to end-users' issues in just three steps! Start your trial here - https://www.telerik.com/fiddler-jam.
Shruti
Top achievements
Rank 1
commented on 15 Oct 2021, 07:55 PM | edited

I am not sure if there is a way to use .Net 6 RC1 instead of RC2 since it gets installed along with Visual Studio. Is there any other to test out Telerik UI controls?
Lance | Manager Technical Support
Telerik team
commented on 15 Oct 2021, 08:13 PM

You're correct that the latest version of VS 2022 preview is responsible for installing RC2 (thus unremovable). Unfortunately, I'm not aware of a way to get around this because the MAUI TFMs don't specific the exact version of NET6 (e.g. net6.0-android, etc.).

I got confirmation from the PMs that we expect to have the next release of UI for MAUI available towards the end of the month. This is when you'll be able to use UI for MAUI again.

I do have a suggestion that you might be able to try. You can install RC1 on a Mac or VM/PC that doesn't have the latest RC2 on it and use CLI to do the builds. Though, this might be just as tricky (or impossible) because the Microsoft MAUI dotnet workloads that you need to install will probably get pulled in for RC2.

Tags
General Discussions
Asked by
Shruti
Top achievements
Rank 1
Answers by
Lance | Manager Technical Support
Telerik team
Share this question
or