This is a migrated thread and some comments may be shown as answers.
runAllManagedModulesForAllRequests
7 Answers 62 Views
This is a migrated thread and some comments may be shown as answers.
msigman
Top achievements
Rank 2
msigman asked on 05 Jan 2011, 11:51 PM
I set this to false in my web.config and haven't noticed any issues.  Is there any reason that Telerik sets this to true by default?

7 Answers, 1 is accepted

Sort by
0
Pavel
Telerik team
answered on 06 Jan 2011, 08:10 AM
Hi msigman,

In fact this setting is added automatically by VS 2010. Just make a new website and you will see it in the web.config. You can read more about what it does here.

Best wishes,
Pavel
the Telerik team
Browse the vast support resources we have to jump start your development with RadControls for ASP.NET AJAX. See how to integrate our AJAX controls seamlessly in SharePoint 2007/2010 visiting our common SharePoint portal.
0
msigman
Top achievements
Rank 2
answered on 10 Jan 2011, 12:44 AM
I just noticed it because when I run the "configure application" wizard from the Telerik menu in VS2010, it changes my web.config file and adds additional information in the <modules> tag: <modules runAllManagedModulesForAllRequests="true">  
0
Petar
Telerik team
answered on 11 Jan 2011, 10:27 AM
Hello Matthew,

There is no particular reason that we set it to true.

It seems that a better behaviour would be not to change this attribute's value and leave it as it is. Saying this means that we will change the behavior for the next official  release of the RadControls for ASP.NET Ajax.

Thank you for the feedback!

All the best,
Petar
the Telerik team
Browse the vast support resources we have to jump start your development with RadControls for ASP.NET AJAX. See how to integrate our AJAX controls seamlessly in SharePoint 2007/2010 visiting our common SharePoint portal.
0
johnsk
Top achievements
Rank 1
answered on 17 Oct 2012, 03:01 AM
Hello!

I have encountered this setting again in VS2012 Kendo UI MVC 4 template with runAllManagedModulesForAllRequests being set to true. Even though this setting may incur aditional performance overhead and unexpected behavior.

As per standard VS2012 MVC4 internet application template this setting is not present in web.config.

Also there is another potential security issue setting in the kendo ui template <add key="webpages:Enabled" value="true" />, which again by default in the standard MVC4 internet application template it is set to false.

Cheers!
0
Petar
Telerik team
answered on 18 Oct 2012, 12:06 PM
Hi John,

Thank you for contacting us!

Both issues are logged in our Public Issue Tracker:
http://www.telerik.com/support/pits.aspx#/public/aspnet-mvc/13008
http://www.telerik.com/support/pits.aspx#/details/Issue=9465

You and other clients can vote and track their state. You are raising the priority of the issues thus I hope to have them fixed soon.

Greetings,
Petar
the Telerik team
If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
0
Fit2Page
Top achievements
Rank 1
Iron
answered on 25 Jun 2014, 10:53 AM
I think this parameter is still set to true when upgrading from VS2013.

has this never been changed?

I tried with Q2 2014...

Marc
0
Petar
Telerik team
answered on 30 Jun 2014, 10:19 AM
Hello Marc,

The issue is still pending. Here is the new url that points to it - http://feedback.telerik.com/Project/108/Feedback/Details/119128-system-webserver-modules-runallmanagedmodulesforallrequests-attribute-is-always.

We don't have exact plans for fixing it yet due to its low priority.

Regards,
Petar
Telerik
 

Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

 
Asked by
msigman
Top achievements
Rank 2
Answers by
Pavel
Telerik team
msigman
Top achievements
Rank 2
Petar
Telerik team
johnsk
Top achievements
Rank 1
Fit2Page
Top achievements
Rank 1
Iron
Share this question
or