Report Total help

5 posts, 0 answers
  1. Brenden
    Brenden avatar
    4 posts
    Member since:
    Jan 2015

    Posted 27 Jan 2015 Link to this post

    Hello Support,

    Like many users here, I am new to reporting. I have been going through the documentation and examples. I just can't seem to wrap my mind around the Totaling part of reports.

    My question is, how do I add a Total Field (for example Price), if I went through the Report Wizard? I used a table layout.

    I know you can do it as follows:
    The way I can do it is, create a blank report, bind my SQL data source to the Report. Drag in the fields, then and a group section for totaling.

    I like the table layout and the snap to grid... so I want to try getting it working without binding it to the report.

    Hope this makes sense, apologies if it has been asked before, I looked around for a while and could not find the exact question

    Thank you
    Brenden
  2. Hinata
    Hinata avatar
    146 posts
    Member since:
    Dec 2013

    Posted 28 Jan 2015 in reply to Brenden Link to this post

    Hi Brenden,

    You can use the same approach with the table. Select the table and open the group explorer. You can add a parent group there or you can "insert row/column outside group" in the context menu of the table. The last option is shown in here: http://www.telerik.com/help/reporting/table-working-with-table-cross-table-list-items.html
  3. Brenden
    Brenden avatar
    4 posts
    Member since:
    Jan 2015

    Posted 03 Feb 2015 in reply to Hinata Link to this post

    Thank you, I see how it works now.
  4. Brenden
    Brenden avatar
    4 posts
    Member since:
    Jan 2015

    Posted 03 Feb 2015 Link to this post

    Hi Hardik,

    I posted earlier today. I know there is a 72 hour turn around time. But I really have no idea why mt Report Viewer toolbar is not functional??

    I have followed the examples, Googled pretty much all day and still cant find the answer. When I run my reports from the Visual Studio or my local server. I am unable to page forward or backwards? The Tool bar will say 0 of 5 pages.

    1 Page of data is present, but paging through doesn't work, when I type in a page number and try refresh this doesn't work either..

    When I inspect the html code I notice the class on the button is "DisabledButton" and not "NormalButton"

    Some how when this report is generating, the toolbar paging does not reckonise the amount of records being pulled back??? Switching to printview is the same, I cant page and I only get the first page of data.

    Still says page 0 of 5 (any number)... Why would it be page 0?

    Any help as quick as you can will be greatly apprecitated.

    thank you

  5. Stef
    Admin
    Stef avatar
    3610 posts

    Posted 06 Feb 2015 Link to this post

    Hello Brenden,

    Please check my reply to "Paging not being picked up", which can be found in your in your Telerik account, and send us the requested details in order to investigate the problem further.

    Thank you for your cooperation.

    Regards,
    Stef
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
Back to Top