This is a migrated thread and some comments may be shown as answers.

RadMaskedTextBox not working with Mobile Browsers

21 Answers 90 Views
Input
This is a migrated thread and some comments may be shown as answers.
Charles
Top achievements
Rank 1
Charles asked on 15 Oct 2013, 08:50 PM
The RadMaskedTextBox does not work properly with the stock android mobile browsers or Chrome for android. Any plans to fix this?

Charles

21 Answers, 1 is accepted

Sort by
0
Marin
Telerik team
answered on 18 Oct 2013, 09:38 AM
Hi,

 You can check out the following demo showingRadMaskedTextBox features and also working on mobile devices:
http://demos.telerik.com/aspnet-ajax/input/examples/radmaskedtextbox/firstlook/defaultcs.aspx
Let me know if there any specific steps or setup necessary to replicate the issue of in your case and which feature exactly does not work as expected.

Regards,
Marin
Telerik
If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to the blog feed now.
0
Charles
Top achievements
Rank 1
answered on 18 Oct 2013, 12:12 PM
To reproduce the problem, take an android phone and go to the link you just sent me. On that page, click in one of the masked text boxes and start typing. The cursor jumps around and the characters will randomly appear and disappear. The control is totally inoperable. I have tested this on the stock android browser and the chrome browser on a Samsung GS4 and an HTC Thunderbolt.
0
Marin
Telerik team
answered on 23 Oct 2013, 03:31 PM
Hi,

 We replicated the problem and it has been logged in our feedback portal. We will try to resolve it for future versions of the controls.

Regards,
Marin
Telerik
If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to the blog feed now.
0
Robert
Top achievements
Rank 1
answered on 17 Jun 2014, 03:27 PM
Is it possible to be notified when this is fixed and in what release?
0
Marin
Telerik team
answered on 20 Jun 2014, 06:43 AM
Hi,

You can track the item and its progress in the feedback portal by clicking the "Follow This Item" button:
http://feedback.telerik.com/Project/108/Feedback/Details/63810-fix-radmaskedtextbox-does-not-work-properly-on-android-devices

Regards,
Marin
Telerik
 

Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

 
0
Yan
Top achievements
Rank 1
answered on 26 Feb 2015, 04:18 PM
Is it possible to get an update on this issue.  On our website,  we use the latest telerik version and we have a postal code RasMaskedTextBox.  It works flawlessly except on android browser.  User tries to start entering a postal code and the cursor jump right to the end.

No android 4.2 users can use our website.  This is a major issue for us.  I would appreciate to get feedback on when do you think this issue will be solved.  Thank you
0
Marin
Telerik team
answered on 27 Feb 2015, 02:34 PM
Hello,

Can you try setting the following property of the MaskedTextBox:
SelectionOnFocus="CaretToBeginning"
We tested it on our side and it should improve the behavior for old android versions.

Let me know how this works in your case and if you have any other questions.

Kind Regards,
Marin
Telerik
 

Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

 
0
Yan
Top achievements
Rank 1
answered on 27 Apr 2015, 07:38 PM

Hi,  

 I've tried to set SelectionOnFocus="CaretToBeginning" with no luck.  Android users are still unable to use our website when on native android browser.  We loose a lot of money because of this bug.  I'm quite dissapointed by this control and how such a big bug (all android users) isn't fixed after all the tickets/blog post we've openned.

 

Still,  thank you Marin

0
Marin
Telerik team
answered on 30 Apr 2015, 10:13 AM
Hello,

We are working on the issue to determine if and how this behavior can be improved. It is more of browser limitation because some older mobile browsers do not fire important events like keypress which is crucial for the masked textbox.
Additionally the native android browser is slowly being replaced by the more modern Chrome browser serving as the default browser in a lot of the latest Android versions, which should work correctly with MaskedTextBox.

We will keep you updated on the progress of the issue.

Regards,
Marin
Telerik
 

See What's Next in App Development. Register for TelerikNEXT.

 
0
Yan
Top achievements
Rank 1
answered on 11 May 2015, 12:48 PM

Hi,  thank you for your reply.

Lets hope you will find something and update the dll because we have a lot of customers calling us telling they can't use our website when on tablet or mobile.  Even if native android browser is slowly being replaced,  I consider this a major issue.  Let us know if this situation gets fixed.

Thank you!

0
Yan
Top achievements
Rank 1
answered on 21 May 2015, 01:50 PM
could someone at least provide an ETA please?
0
Marin
Telerik team
answered on 26 May 2015, 02:54 PM
Hi,

We will try to have definite answer whether this problem can be fixed or if it is a browser limitation for the next service pack of the controls.

Regards,
Marin
Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
0
Yan
Top achievements
Rank 1
answered on 26 May 2015, 03:28 PM
Thank you for the reply,  can't wait to see it fixed if it can be!
0
Yan
Top achievements
Rank 1
answered on 05 Jun 2015, 06:47 PM

Any updates? when is the next release?

 

Thank you!

0
Marin
Telerik team
answered on 09 Jun 2015, 10:43 AM
Hello,

The next official release is at the end of June but new development and fixing for this release is pretty much over and now we are in testing phase to ensure it is stable and ready to deploy in production.
That's why I mentioned in my previous post the service pack which normally comes about one month after an official release.
We will have a more detailed looked at this issue as soon as we have the chance and I will post here our findings right away - but again it is very likely that is a browser limitation which cannot be resolved through code.
Testing environment is also important in order to properly replicate the problem - can you share on what devices and android versions you can replicate this problem? The behavior of the native android browser may deffer depending on the mobile device vendor and the OS version - that's why it is important to know if all devices with native android browser experience this issue.

Kind Regards,
Marin
Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
0
Yan
Top achievements
Rank 1
answered on 10 Jun 2015, 02:23 PM

Hi thank you for your answer,  it is happening on all native android broser i've tested it.

 Right now,  I'm testing it using Galaxy S5 running 5.0 firmware

0
Marin
Telerik team
answered on 15 Jun 2015, 01:17 PM
Hello,

Thank you for the information, we will test this configuration as well while looking for a solution to the problem.

Regards,
Marin
Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
0
Yan
Top achievements
Rank 1
answered on 10 Jul 2015, 02:29 PM
hi,  any update regarding this issue?
0
Marin
Telerik team
answered on 14 Jul 2015, 04:12 PM
Hello,

Currently we are performing extensive testing on various devices and emulators with different versions of android in order to track down and isolate the root cause of the problem. We have tested the native android browser on android version: 4.0, 4.2, 4.4, 5.0 and 5.1
Can you verify if the issue can be replicated on the attached simple test page containing only a RadMaskedTextBox running with the latest Telerik assemblies (also attached in the project)
If possible also share whether you replicate the problem in Chrome (on the same device) or only on the native android browser, the model of the mobile device will also be helpful since different vendors may have different versions of the default browser.
This information will help us to verify if we are observing the same behavior as you do.

Thank you for your cooperation.

Regards,
Marin
Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
0
Yan
Top achievements
Rank 1
answered on 07 Dec 2015, 02:59 PM

Hi,  thank you for the reply.  We've just upgraded our telerik dll to the latest and everything works fine for now when testing with my android 5.1

 Problem was only happening with android native browser.  Chrome was working perfectly.  

 

Thank you!

0
Marin
Telerik team
answered on 08 Dec 2015, 08:44 AM
Hi,

I'm glad to hear everything is ok now.

Regards,
Marin
Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Tags
Input
Asked by
Charles
Top achievements
Rank 1
Answers by
Marin
Telerik team
Charles
Top achievements
Rank 1
Robert
Top achievements
Rank 1
Yan
Top achievements
Rank 1
Share this question
or