This is a migrated thread and some comments may be shown as answers.

RadInputManager IndexSizeError in Firefox 32

2 Answers 32 Views
Input
This is a migrated thread and some comments may be shown as answers.
Sypher
Top achievements
Rank 1
Sypher asked on 29 Sep 2014, 08:44 PM
I'd post this as a support ticket, but our support just ran out last week (of course)...

This seems to be a new issue with 2014.2.724.45, as the exact same code is working on our production site but is giving this error in Firefox on our Beta site

IndexSizeError: Index or size is negative or greater than the allowed amount

The error shows up in the if(c.originalMaxLength) line below

updateValue:function(d){var c=$get(this._id);
var e;
var f=c.value;
if(c.originalMaxLength){c.maxLength=c.originalMaxLength;
}if(typeof(d)=="undefined"){e=c.value;

This is showing up on our Login page that uses telerik:RadInputManager to make the user name and password fields required.

<telerik:RadInputManager runat="server" ID="rim">
    <telerik:TextBoxSetting BehaviorID="textRequired">
        <Validation IsRequired="true" />
        <TargetControls>
            <telerik:TargetInput ControlID="UserName" />
            <telerik:TargetInput ControlID="Password" />
        </TargetControls>
    </telerik:TextBoxSetting>
</telerik:RadInputManager>

If I comment out the RadInputManager, the page works fine, although without validation. If I leave the code in, we get the error message in the Firebug console in Firefox 32.0.3 and the password box won't accept any typing at all. It works fine in IE and Chrome.

Live beta site example at https://beta.connectionsonline.net/

I noticed that Mozilla has a similar issue listed as a bug with Firefox 30 and 31, but I'm not sure if it is related: https://bugzilla.mozilla.org/show_bug.cgi?id=987227

2 Answers, 1 is accepted

Sort by
0
Accepted
Vasil
Telerik team
answered on 30 Sep 2014, 12:22 PM
Hi sypher,

This issue happened when we fixed a bug in IE, where the form was not able submit if the empty message in given field was longer than the max length set for the input.

By that time it worked correct in all browsers, but then Firefox introduced browser bug.
When a Input element have not max length set the its maxLength property returns "-1" instead of 0.

So when you get the max length, and then try to set the same max length the browser throw error that says -1 is not permitted value for the maxLength attribute.

We have fixed this, and if you test the hotfix builds it should work correct. In the upcoming beta that will be released this week it should work correct as well.

Regards,
Vasil
Telerik
 

Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

 
0
Sypher
Top achievements
Rank 1
answered on 01 Oct 2014, 04:16 PM
Adding a MaxLength fixed it for me. I assume I no longer have access to the betas/fixes/etc.
Tags
Input
Asked by
Sypher
Top achievements
Rank 1
Answers by
Vasil
Telerik team
Sypher
Top achievements
Rank 1
Share this question
or