RadEditor is sometime no longer able to format content correctly

4 posts, 0 answers
  1. Anthony Clenet
    Anthony Clenet avatar
    2 posts
    Member since:
    Jun 2009

    Posted 22 Sep 2009 Link to this post

    I am using the fully featured RadEditor for MOSS v5.4.

    Sometimes, the component is no longer able to format content correctly. Usually, this occurs when lines or bullets are at the end of the text. It becomes impossible to remove unnecessary lines. Users must edit content with the HTML editior which is not so simple for standard users ...

    Is there a fix for this?

    Below code that is problematic : Delete lines of text at the end after the table element (do several tests if the lines disappear after validating the content. The behavior is a bit random. ;-)  ).

    <p style="text-align: center;"><span style="font-size: 18px; color: #37992a; font-family: arial;"><strong>Bienvenue dans Négoce Village !<br />

    </strong></span><span style="font-size: 13px; font-family: arial;"><strong><span style="font-size: 18px;"><span style="color: #37992a;">Le site des entreprises de négoce</span> <br />

    </span></strong><span style="font-size: 24px; color: #37992a;">

    <p style="text-align: left;"><span style="font-size: 13px; color: #000000; font-family: arial;"><strong>450 entreprises, 6 milliards de chiffre d'affaires, 11.000 personnes.<br />

    <br />

    </strong></span><span style="font-size: 13px; color: #000000;"><strong>Pour les activités d’agrofourniture,</strong> conseil, préconisation, distribution des intrants (fertilisants, produits phytopharmaceutiques, semences aliments pour animaux).<br />

    </span><span style="color: #000000;"><span style="font-size: 13px;"><strong><br />

    Pour le commerce des céréales oléagineux et protéagineux,</strong> collecte des productions, stockage, mise aux normes, commercialisation sur le marché intérieur et l’export.<br />

    </span> <br />

    </span><strong><span style="font-size: 32px;">

    <table align="center">






                <p style="text-align: center;"><span style="font-size: 32px; color: #37992a;"><strong>Prochain Congrès<br />

                 du Négoce Agricole<br />

                </strong></span><span style="color: #000000;"><span style="font-size: 24px;"><strong>vendredi 27 novembre 2009<br />

                </strong> à</span><span style="font-size: 24px;"> la bourse de commerce de Paris</span></span><span style="font-size: 24px;"> </span></p>






    <p style="text-align: center;"> </p>

    <p style="text-align: center;"> </p>


    <p style="text-align: center;"> </p>

    <p style="text-align: left;"> </p>



    <p style="text-align: center;"> </p>

    <p> </p>

    <p style="text-align: center;"> </p>

    <p> </p>

    <p> </p>

    <p style="text-align: center;"> </p>

    <p> </p>

  2. Vyrban
    Vyrban avatar
    31 posts
    Member since:
    Nov 2008

    Posted 24 Sep 2009 Link to this post

    Why don't you try to set property ContentFilters = "none" (in the configuration file, depends on your scenario). Does it help?
  3. Ian
    Ian avatar
    1 posts
    Member since:
    Oct 2009

    Posted 26 Oct 2009 Link to this post

    Our users are experiencing the same problem.  I was told it was the editor trying to correct what it considers faulty HTML.  Does anyone know if the solution suggested by Vyrban works?

    Thanks in advance.

  4. Rumen
    Rumen avatar
    13244 posts

    Posted 29 Oct 2009 Link to this post

    Hi Ian,

    Please, note that it is the browser's Rich Text Editing engine that tries to validate the non well formed content and after that the RadEditor filters. In this scenario it is best to only disable the ConvertToXhtml and ConvertFontToSpan filters of RadEditor which is mislead by this browser change.

    More information about the built-in filters of RadEditor is available here.

    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
Back to Top