Problem with loss of popup ability related to web server?

3 posts, 0 answers
  1. Boris
    Boris avatar
    289 posts
    Member since:
    Oct 2012

    Posted 19 Jan 2015 Link to this post

    This may be premature.  This may or may not be an Ajax problem, but here goes.

    I have identical code deployed to 2 web servers (dev and production).  There are 2 main problems as far as I can tell, both Internet Explorer related.  On one site the app works perfectly in all browsers including IE.  In the other it works perfectly in Chrome and Firefox but not IE. 

    The page has a master page containing a RadScriptManager,  RadCodeBlock,   RadStyleSheetManager,  RadSkinManager, and and asp:Repeater populated with Asp:Link buttons.
    The page itself contains a RadInputManager,  RadWindowManager,  RadToolTipManager, 2  RadCodeBlocks, and the  RadGrid itself.

    Problem 1 is that in IE, the asp:Repeater is disabled.  The set of links is populated and displays correctly but they simply don't work.

    Problem 2 is that various hyperlinks in the RadGrid also do not work in IE. (Also generated in code.)  The idea is that these hyperlinks call a JavaScript function which in turn calls up a popup window.  

    (As far as I can remember I copied this pattern directly from Telerik.
    The calls are like this:   var oWnd = window.radopen("EditWindow.aspx?Id=" + Id, "Add Entry For Record " + Id);   )  

    All these calls crash, giving a message saying that the window object is null.

    Troubleshooting this problem is complicated by the fact that I do not have direct access to the production server due to security concerns.  A friend of mine has suggested that this might be due to some sort of permissions problem in IIS.

    Anyone else have a problem like this?
  2. Danail Vasilev
    Danail Vasilev avatar
    1502 posts

    Posted 22 Jan 2015 Link to this post

    Hi Boris,

    The mentioned errors doesn't seem to be directly related to Telerik UI controls but something general in the web app/site. You can try to reproduce the issue on a page that contains no Telerik UI controls. If the issues are still reproducible then they are not related to Telerik UI controls and possible causes must be searched somewhere else.

    I can also suggest that you try the following troubleshooting steps:
        - Are there any JavaScript errors on your page? If there are such errors they must be fixed.
        - If you are not using latest Telerik UI version - 2014.3.1209, does upgrading to it helps?
        - You can try to disable the AJAX, in order to ensure the problem is not AJAX related. This can be done through the EnableAJAX property of the RadAjaxManager/RadAjaxPanel.
        - Since the issue is only reproducible in IE it may be related to the compatibility mode. You can try to fore the browser to edge mode.
        - It may be possible that some browser plug-in is causing the issue. You can try to disable all of the plug-ins and if that helps then start turning them one by one until you find the problematic one.
        - Check your browser requests in order to see whether there are any failing requests.
        - See whether there are any JavaScript syntax errors in your code.
        - Try calling the radopen() method without the window object reference. Note also that radopen() method requres that you have a RadWindowManager instance on your page.
        - Ensure that you are not override the window object or you are calling an external JavaScript outside of the browser. More information on the matter is available in this and this forum posts.

    Danail Vasilev

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

  3. Boris
    Boris avatar
    289 posts
    Member since:
    Oct 2012

    Posted 23 Jan 2015 in reply to Danail Vasilev Link to this post

    Most likely the problems are not specifically Telerik after all.

    Actually the IE10 problems have been solved by admin adjusting the permissions.  (They haven't explained to me yet exactly what they did.)

    As far as IE11 is concerned I'm waiting to see if installing will help.  (We've already tried creating an ie11.browser file but couldn't get that to work.  And apparently installing the 4.5 framework is not an option because it might affect other problems.  (Not sure I understand that myself.)

    As for upgrading to the most recent Telerik, that's politics.  I'm working on it...
Back to Top