Problem in ComboBox accepting "<" character

3 posts, 0 answers
  1. Kevin Kess
    Kevin Kess avatar
    8 posts
    Member since:
    Mar 2010

    Posted 29 Sep 2010 Link to this post

    I had an unsual issue I ran into. When filling a combobox text property from a database pull, my database was coming back with a value of "<no company>" and filling the combobox text property. When I tried to save data back to the database I get the following error, in my studio window (in attached file). If I manually remove the "<" character it is fine. I think the control somehow is having problems accepting the "<" character. It's an unusual condition but still may cause issues for users.


    Kevin Kess


  2. Simon
    Admin
    Simon avatar
    2281 posts

    Posted 29 Sep 2010 Link to this post

    Hi Kevin Kess,

    This is strange - I was unable to reproduce this with a simple RadComboBox. Could you please see the attached page and let me know if I need to modify/add something else to trigger the issue.

    Sincerely yours,
    Simon
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Cori
    Cori avatar
    562 posts
    Member since:
    Jul 2010

    Posted 29 Sep 2010 Link to this post

    Hello Kevin,

    The issue is with ASP.NET not allowing tag-like text from being submitted. The easy way to resolve this issue is to set ValidateRequest="false" in the <%@ Page %> tag at the top of your page.

    I hope that helps.
Back to Top