Parser Error Message: Tried to add NamedPermissionSet with non-unique name.

2 posts, 0 answers
  1. Monique
    Monique avatar
    1 posts
    Member since:
    May 2009

    Posted 01 May 2009 Link to this post


    We have a client system that uses a QA web application and a Production web application. Due to an administrative error, the Rad Editor solution was retracted from both web applications and then redeployed to both web applications. The page we are having issues with functions properly in the QA web app and throws an error in the Production web app.

    I verfied the the DLLs are in the GAC and that the tags are registered as safe in the web.config file. I am new to the setup of this solution and everything appears to be OK with the setup. Any and all help is appreciated. Please see error message below. Thank you!

    Server Error in '/' Application.

    Parser Error

    Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

    Parser Error Message: Tried to add NamedPermissionSet with non-unique name.

    Source Error:

    Line 1:  <%@ Register TagPrefix="WpNs1" Namespace="Microsoft.SharePoint.Portal.WebControls" Assembly="Microsoft.SharePoint.Portal, Version=, Culture=neutral, PublicKeyToken=71e9bce111e9429c"%>
    Line 2: <%@ Register TagPrefix="WpNs0" Namespace="Telerik.SharePoint" Assembly="RadEditorSharePoint, Version=, Culture=neutral, PublicKeyToken=1f131a624888eeed"%>Line 3:  <%@ Page language="C#" MasterPageFile="~masterurl/default.master"    Inherits="Microsoft.SharePoint.WebPartPages.WebPartPage,Microsoft.SharePoint,Version=,Culture=neutral,PublicKeyToken=71e9bce111e9429c" meta:progid="SharePoint.WebPartPage.Document" %>
    Line 4:  <%@ Register Tagprefix="SharePoint" Namespace="Microsoft.SharePoint.WebControls" Assembly="Microsoft.SharePoint, Version=, Culture=neutral, PublicKeyToken=71e9bce111e9429c" %> <%@ Register Tagprefix="Utilities" Namespace="Microsoft.SharePoint.Utilities" Assembly="Microsoft.SharePoint, Version=, Culture=neutral, PublicKeyToken=71e9bce111e9429c" %> <%@ Import Namespace="Microsoft.SharePoint" %> <%@ Register Tagprefix="WebPartPages" Namespace="Microsoft.SharePoint.WebPartPages" Assembly="Microsoft.SharePoint, Version=, Culture=neutral, PublicKeyToken=71e9bce111e9429c" %>

    Source File: /default.aspx    Line: 2

    Version Information: Microsoft .NET Framework Version:2.0.50727.3082; ASP.NET Version:2.0.50727.3082
  2. Lini
    Lini avatar
    2144 posts

    Posted 05 May 2009 Link to this post

    Hi Monique,

    Try raising the Trust level of the production web application and/or restarting the IIS services on the production server. Check if there are any differences in the Web.config files between the two servers.

    I could not find any other references to this error in our forum and I am not sure what causes it. The suggestions above will make sure that the applications on your QA and Production web applications are running with the same configuration. Hopefully this will resolve the issue. One last thing you should check is the c:\Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE\CONTROLTEMPLATES\ folder on the two servers and make sure they are the same.

    Sincerely yours,
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
Back to Top