OnClientNodeExpanding not firing for ServerSideCallback

4 posts, 0 answers
  1. ali
    ali avatar
    17 posts
    Member since:
    Jan 2009

    Posted 24 Mar 2009 Link to this post

    Hi,
    I have a node whose ExpandMode prop is set to ServerSideCallback. When I click the + on the node the OnClientNodeExpanding JAvascript function executes. If I try to expand it using the keyboard however, this javascript method does not fire.


  2. Atanas Korchev
    Admin
    Atanas Korchev avatar
    8462 posts

    Posted 24 Mar 2009 Link to this post

    Hi ali,

    This is a known issue which we will try to address in the upcoming service pack. Thank you for your understanding.

    Regards,
    Albert
    the Telerik team

    Check out Telerik Trainer , the state of the art learning tool for Telerik products.
  3. ali
    ali avatar
    17 posts
    Member since:
    Jan 2009

    Posted 25 Mar 2009 Link to this post

    Hi,
    I have also noticed that the same problem occurs when a node is dragged and hovered above another node. When this node expands it fails to call the OnClientNodeExpanding JAvascript function.

    Can you just confirm that this will also be fixed in the service pack.
  4. Atanas Korchev
    Admin
    Atanas Korchev avatar
    8462 posts

    Posted 25 Mar 2009 Link to this post

    Hello ali,

    We will investigate this issue further and try to fix it for the upcoming release.

    Regards,
    Albert
    the Telerik team

    Check out Telerik Trainer , the state of the art learning tool for Telerik products.
Back to Top