This is a migrated thread and some comments may be shown as answers.

Need to remove the first column (Enabled false) one from the raddate picker popup

8 Answers 60 Views
Calendar
This is a migrated thread and some comments may be shown as answers.
Thenmozhi
Top achievements
Rank 1
Thenmozhi asked on 18 Apr 2011, 07:41 AM
Hi,

Can any one help me on this.

I want to remove the first column (Enabled false) one from the raddate picker calender popup.

Please refer my attachment for detail.

Thanks in Advance,

Thenmozhi.R

8 Answers, 1 is accepted

Sort by
0
Accepted
Maria Ilieva
Telerik team
answered on 20 Apr 2011, 04:38 PM
Hello Thenmozhi,

In order to hide the row header column from the calendar please set ShowRowHeaders="false"

Regards,
Maria Ilieva
the Telerik team

Browse the vast support resources we have to jump start your development with RadControls for ASP.NET AJAX. See how to integrate our AJAX controls seamlessly in SharePoint 2007/2010 visiting our common SharePoint portal.

0
Thenmozhi
Top achievements
Rank 1
answered on 22 Apr 2011, 11:47 AM
Hi,

I would like to remove the first column not the row..

Please see the attachment (Red marked one i want to hide for the users.)

Thanks
Thenmozhi
0
Accepted
Dean
Top achievements
Rank 2
answered on 22 Apr 2011, 03:04 PM
Hi Thenmozhi,

There are 2 settings for the calendar view, ShowRowHeaders and ShowColumnHeaders.

Please see attached image for examples of both options. As Maria Ilieva has pointed out, using (ShowRowHeaders = False) will produce what you are loooking for.



0
Thenmozhi
Top achievements
Rank 1
answered on 25 Apr 2011, 07:09 AM
This is my exact requirement.

Thanks.
0
Jorge
Top achievements
Rank 1
answered on 05 Jul 2012, 03:34 PM
And how do you go about making this change application-wide, without having to touch every single date picker?
Thanks in advance!
0
Princy
Top achievements
Rank 2
answered on 06 Jul 2012, 09:36 AM
Hi Jorge,

Try overriding the default css as follows.

CSS:
<style type="text/css">
  .RadCalendar .rcRow th
    {
      display: none !important;
    }
</style>

Hope this helps.

Thanks,
Princy.
0
Jorge
Top achievements
Rank 1
answered on 06 Jul 2012, 01:50 PM
Thanks for the reply Princy, but that did not work. Your solution did not remove the week column.

The best solution I have found is to create a skin file (not the Telerik interpretation of skins.)
By creating an ASP.Net skin I was able to inherit the ShowRowHeaders="false" parameter in all the date pickers application-wide, without having to hack styles or touch a single date picker.

I just cannot understand why Telerik has not changed this very unwanted default. If you do a Google search for this issue, it is clearly evident that most developers DO NOT want that week-of-the-year column, as they all seem to be looking for a way to turn it off. You will also notice that the inquiries and complaints date way back to 2006 or before... It is mind boggling but not surprising to me that this issue has not been addressed by Telerik.
0
Maria Ilieva
Telerik team
answered on 10 Jul 2012, 11:19 AM
Hi Jorge,

We will further review all requirements we have regarding this change and will discuss its possible implementation in some of the future release of the control.

Thank you for sharing your solution and feedback.

Regards,
Maria Ilieva
the Telerik team
If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
Tags
Calendar
Asked by
Thenmozhi
Top achievements
Rank 1
Answers by
Maria Ilieva
Telerik team
Thenmozhi
Top achievements
Rank 1
Dean
Top achievements
Rank 2
Jorge
Top achievements
Rank 1
Princy
Top achievements
Rank 2
Share this question
or