Navigation buttons not working

3 posts, 0 answers
  1. Greg
    Greg avatar
    5 posts
    Member since:
    Jun 2020

    Posted 14 Sep 2020 Link to this post

    When I run my application using RadScheduler from Visual Studio, everything works properly.

    When I publish it to an Azure Web App, some of the features stop working.

    My default view is Week. I can create, edit, adjust or move appointments within that week without any issues.

    • I can't use the back/forward arrow keys to select a different week
    • I can't switch to a different view (Day, Month, Agenda)
    • I can't use the arrow keys to select a different week.

    I have the latest version of Telerik UI for ASP.NET Ajax installed along with the latest version of Visual Studio 2019.

    I'm not getting any error messages of any sort. The most frustrating part is that when I go back to my development environment to try to diagnose the problem (inside Visual Studio) everything works properly. So, I'm at a loss to explain why it would behave differently on Azure than inside Visual Studio.

     

  2. Peter Milchev
    Admin
    Peter Milchev avatar
    880 posts

    Posted 15 Sep 2020 Link to this post

    Hello Greg,

    Did you check the Console tab of the DevTools(F12) for any JavaScript errors? 

    Also, please inspect the Network tab in the DevTools(F12) for any failing request:

    If that issue persists, please share a live URL where we can observe the faulty behavior.

    Regards,
    Peter Milchev
    Progress Telerik

    Five days of Blazor, Angular, React, and Xamarin experts live-coding on twitch.tv/CodeItLive , special prizes and more, for FREE?! Register now for DevReach 2.0(20).

  3. Greg
    Greg avatar
    5 posts
    Member since:
    Jun 2020

    Posted 15 Sep 2020 in reply to Peter Milchev Link to this post

    Thank-you for your suggestions...Still not entirely sure why it worked properly in DevStudio, but it was clear that the DB connection was being dropped after refresh on website. I juggled the connection management in the Page_OnLoad for the page and solved the problem.
Back to Top