This is a migrated thread and some comments may be shown as answers.

move to next cell for radgrid in Batch mode editing

6 Answers 221 Views
Grid
This is a migrated thread and some comments may be shown as answers.
Bary
Top achievements
Rank 1
Bary asked on 21 Jul 2014, 02:44 PM
Hello,

I am using the radgrid in Batch mode editing, I want to be able to move to next cell while adding new record or editing by pressing the Tab key, is that possible?

I have set AllowKeyboardNavigation="true".

Is there any sample for that.

Thanks in advance

Bary

6 Answers, 1 is accepted

Sort by
0
Eyup
Telerik team
answered on 24 Jul 2014, 10:41 AM
Hello Bary,

Can you please confirm that you are using the latest release version of the controls? You can verify that the keyboard navigation of Batch editing works as described in the following live sample:
http://demos.telerik.com/aspnet-ajax/grid/examples/data-editing/batch-editing/defaultcs.aspx

Looking forward to your reply.

Regards,
Eyup
Telerik
 

Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

 
0
Bary
Top achievements
Rank 1
answered on 25 Jul 2014, 09:38 AM
Hello Eyup,

Thanks for your answer.

Yes the demo is working as expected, but on my project it's not.

The version I'm using is 2014.2.618.45, I think it's the latest version for now.

I paste my markup, so you can take a look on it:

<body>
    <form id="form1" runat="server">
        <telerik:RadScriptManager ID="RadScriptManager1" runat="server"></telerik:RadScriptManager>
        <asp:EntityDataSource ID="EDSR" runat="server" ConnectionString="name=HMSEntities" DefaultContainerName="HMSEntities" EnableDelete="True" EnableFlattening="False" EnableInsert="True" EnableUpdate="True" EntitySetName="Rates"></asp:EntityDataSource>
        <telerik:RadGrid ID="rgRates" runat="server" AllowPaging="True" DataSourceID="EDSR" AllowAutomaticUpdates="True" AllowAutomaticInserts="True" AllowAutomaticDeletes="True" AutoGenerateColumns="False" CellSpacing="-1" GridLines="Both">
            <MasterTableView Width="100%" DataKeyNames="RateId" CommandItemDisplay="Top" EditMode="Batch" BatchEditingSettings-OpenEditingEvent="Click" AutoGenerateColumns="False">
                <BatchEditingSettings EditType="Cell" />
                <Columns>
                    <telerik:GridBoundColumn DataField="SGL" DataType="System.Decimal" HeaderText="SGL" SortExpression="SGL" UniqueName="SGL">
                        <ColumnValidationSettings>
                            <ModelErrorMessage Text="" />
                        </ColumnValidationSettings>
                    </telerik:GridBoundColumn>
                    <telerik:GridBoundColumn DataField="DBL" DataType="System.Decimal" HeaderText="DBL" SortExpression="DBL" UniqueName="DBL">
                        <ColumnValidationSettings>
                            <ModelErrorMessage Text="" />
                        </ColumnValidationSettings>
                    </telerik:GridBoundColumn>
                    <telerik:GridBoundColumn DataField="TPL" DataType="System.Decimal" HeaderText="TPL" SortExpression="TPL" UniqueName="TPL">
                        <ColumnValidationSettings>
                            <ModelErrorMessage Text="" />
                        </ColumnValidationSettings>
                    </telerik:GridBoundColumn>
                    <telerik:GridBoundColumn DataField="Quad" DataType="System.Decimal" HeaderText="Quad" SortExpression="Quad" UniqueName="Quad">
                        <ColumnValidationSettings>
                            <ModelErrorMessage Text="" />
                        </ColumnValidationSettings>
                    </telerik:GridBoundColumn>
                    <telerik:GridBoundColumn DataField="AEBED" DataType="System.Decimal" HeaderText="AEBED" SortExpression="AEBED" UniqueName="AEBED">
                        <ColumnValidationSettings>
                            <ModelErrorMessage Text="" />
                        </ColumnValidationSettings>
                    </telerik:GridBoundColumn>
                </Columns>
            </MasterTableView>
            <ClientSettings AllowKeyboardNavigation="true">
            </ClientSettings>
        </telerik:RadGrid>
    </form>
</body>
 
Thanks in advance
Bary

0
Accepted
Konstantin Dikov
Telerik team
answered on 30 Jul 2014, 06:37 AM
Hi Bary,

Actually, with version 2014.2 618 there was an issue with the tabbing functionality of Batch edit mode and I assume that if you inspect your browser's console you will notice that a JavaScript error is thrown when you try to tab between the cells.

However, this bug is already fixed in our latest release, version 2014.2 724, so could you please update to our latest and see if everything works as expected.

Hope this helps.


Regards,
Konstantin Dikov
Telerik
 

Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

 
0
Bary
Top achievements
Rank 1
answered on 30 Jul 2014, 08:42 AM
Hello Konstantin,

Yes, the version 2014.2 724 fixes this issue.

Thank you
0
Brian
Top achievements
Rank 1
answered on 30 Oct 2014, 02:21 PM
We're using v 2014.1.403.40 and the following block of code does not work (i.e) I clicking outside the row, or even saving, it lets us save or move around without filling this required field. Btw, the grid is in Batch Mode. What am I missing?

Also, is there a way to increase the default editor size (text box size height and width) on insert and update?

<MasterTableView CommandItemDisplay="Top" DataKeyNames="InvNum,InvDbId,InvNotesNum,Note" 
           AutoGenerateColumns="False" DataSourceID="objDataSourceIN" HorizontalAlign="NotSet" EditMode="Batch">
..............
<telerik:GridBoundColumn DataField="Note" HeaderStyle-Width="410px" HeaderText="Notes" SortExpression="Note"
                    UniqueName="Note">
      <ColumnValidationSettings EnableRequiredFieldValidation="true">
            <RequiredFieldValidator ForeColor="Red" Text="*This field is required" Display="Dynamic">
            </RequiredFieldValidator>
      </ColumnValidationSettings>
</telerik:GridBoundColumn>


Thanks


0
Konstantin Dikov
Telerik team
answered on 03 Nov 2014, 03:19 PM
Hello Brian,

If you are using .NET 4.5, could you please go through the following forum thread and try the suggested workaround for enabling the validators:
You could also try setting the following in your web.config, which is the easiest way for handling that framework issue:
<appSettings>
  <add key="ValidationSettings:UnobtrusiveValidationMode" value="None" />
  ....
</appSettings>

Hope this helps.


Regards,
Konstantin Dikov
Telerik
 

Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

 
Tags
Grid
Asked by
Bary
Top achievements
Rank 1
Answers by
Eyup
Telerik team
Bary
Top achievements
Rank 1
Konstantin Dikov
Telerik team
Brian
Top achievements
Rank 1
Share this question
or