MAUI - UI Freezing on Nagivation

0 Answers 518 Views
BusyIndicator ListView
Rúben
Top achievements
Rank 1
Rúben asked on 29 May 2023, 11:34 AM

Hello everyone, I write this post in the hope that someone can help me with this problem.

I'm newbie with this MAUI framework. I'm trying to create a simple Android / iOS application but I'm experiencing navigation performance issues.

Whenever I navigate to a page with more "heavy" information, the UI simply freezes until the information is loaded. For example if I use a ListView with only 13 elements the UI freezes for at least one/two seconds, this in release mode cannot be acceptable. I tried to put a Busy Indicator to simulate the loading of the page but it freezes until the information is loaded. It is a very bad user experience.

All my services are running on background threads. I'm currently using Telerik components and I'm also using Shell and the CommunityToolkit.Mvvm package.

On Windows the application works perfectly, without any problem but on Android it is very bad.

I've looked everywhere for a solution. I found some similar problems and most of the proposed solutions were to avoid ListViews nested in scroll views and so on, I already checked all that but nothing changed.

 

Has anyone here ever faced a problem like this? If yes, how did you manage to solve it?

 

Thank you in advance for your attention!

Didi
Telerik team
commented on 30 May 2023, 08:11 AM

Hi Rúben,

Thank you for using Telerik Maui controls. We have not been reported a performance issues with the ListView on android. We have a behavior on iOS and Mac when group header template is used, but the performance is with the scrolling, not data loading https://feedback.telerik.com/maui/1591230-listview-ios-maccatalyst-slow-performance-when-groups-are-sticky-and-group-header-template-is-used  

Next Steps: 
I will need a sample app to test the behavior on my side. What are the exact approaches used in the app, navigation logic, etc. Android device version where the issue happens? 

Looking forward to your reply.

Mark
Top achievements
Rank 3
Iron
Iron
Iron
commented on 12 Jul 2023, 06:20 PM

Hi 

I am having a similar issue, on macOs where the UI is not rendered but the code in the ViewModel is executing (including tasks running in a timer etc) Works in Dev but does not work when installed via TestFlight. But works on Windows and also deployed via the Windows Store. At this point I am not sure if its Telerik specific, but am at the point where I need to rebuild the app and deploy until it fails as I cannot replicate it and don't have any error messages.

I will report back when I get that working.

Have you managed to get past this issue?
Mark
Top achievements
Rank 3
Iron
Iron
Iron
commented on 14 Jul 2023, 07:50 AM

Re my comment above, I have started a new thread for my issue: https://www.telerik.com/forums/combobox-causes-ui-to-not-load-when-testing-in-testflight its not performance related, as UI is just not rendering when adding a Telerik control.
Mark
Top achievements
Rank 3
Iron
Iron
Iron
commented on 14 Jul 2023, 04:42 PM

Just checking back in here, the issue I reported was something completely different and resolved.

No answers yet. Maybe you can help?

Tags
BusyIndicator ListView
Asked by
Rúben
Top achievements
Rank 1
Share this question
or