Issue uploading .csv files using Edge

3 posts, 0 answers
  1. Matthew
    Matthew avatar
    11 posts
    Member since:
    Feb 2015

    Posted 12 Sep 2016 Link to this post


    I noticed in my web application that I was unable to select a .csv file to upload using the AsyncUpload control when using the MS Edge browser.

    I initially though that it must have been excluded by the AllowedFileExtensions property, however found that it was working using Chrome.

    I am not on the latest version of the RadControls but experienced the exact same issue on the demo site below

    I do have the anniversary update of Windows 10 installed and am wondering if it is related.

    My version of Edge is as follows

    Edge 38.14393.0.0

    EdgeHTML 14.14393




  2. Matthew
    Matthew avatar
    11 posts
    Member since:
    Feb 2015

    Posted 14 Sep 2016 in reply to Matthew Link to this post

    It appears to be because the file was downloaded via the browser and Windows had locked it.

    I had a text file that was also locked however and it worked in Edge and both worked in Chrome.

    This is most likely a browser issue and not a Telerik issue but it still a bit confusing for users

  3. Rumen
    Rumen avatar
    14324 posts

    Posted 15 Sep 2016 Link to this post


    Indeed, this is a browser/OS issue, which is not related to the control itself.

    Best regards,
    Telerik by Progress
    Do you need help with upgrading your ASP.NET AJAX, WPF or WinForms projects? Check the Telerik API Analyzer and share your thoughts.
Back to Top