InvalidCastException after purchase

2 posts, 0 answers
  1. Aaron
    Aaron avatar
    25 posts
    Member since:
    Jun 2012

    Posted 16 Jul 2012 Link to this post

    Hello,

    I was running a trial version of Telerik  since about June 15 or so I would guess.  We purchased the toolset on Friday July 13th and it looked as though there was an updated.  I had started using some of the tools inside our project.   When I bring the project up after the install I am getting errors specifically on the radgrid it looks like.  I haven't tried anything else.  If i remove the grid and attempt to re add it to my project as soon as I slide the control on to my project I get the same thing so it seems my toolbox is broke as well.  I tried doing a reset on the toolbox and that did not do anything.  Also, i verified i have the  telerik.web.ui referenced in my project from the bin40 folder as well.  What happened and how do i fix this?

    EDIT:  I forgot to attach the error.  this is what I am getting after we purchased and updated.

    Thanks.
  2. Andrey
    Admin
    Andrey avatar
    836 posts

    Posted 19 Jul 2012 Link to this post

    Hi,

    Thank you for contacting us.

    This most probable reason why you get this error is partially/wrongly updated assembly files. Visual Studio designer is trying to use the old trial assemblies but it could not find them and that is why you receive the error message.

    Depending on the type of Project you are working on there are some steps you could follow:

    • If you are using project type WebSite simple replace of the DLLs in the Bin folder should do the trick, however if you have referenced the DLLs globally in Web.config file you should make correction to the linked version too.
    • If the project is of type WebApplication, you should reference the DLL files and additionally to replace the DLL file in the Lib and Bin folders of your project.

    Beside these specific to the type of project steps, there are two common steps that should be done in order to verify that all references are replaced. First close all opened instances of Visual Studio and then clear the content of these folders:

    • C:\Users\current_user\AppData\Local\Microsoft\VisualStudio\10.0\ProjectAssemblies
    • C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files
    Additionally you could check what is the version of the Telerik assembly which is referenced in the GAC if you have installed it in the GAC. You could check this help topic for more information.

    Give these suggestions a try and let me know if you need further assistance.

    All the best,
    Andrey
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
Back to Top